
Working with Pipeline Records

This section explains how to work with folders and pipelines in the system hierarchy tree. 
The information is intended for users with SysAdmin user permissions unless noted 
otherwise. 

Topics in section include those in the following list:

• Adding a Folder in the Hierarchy (page 139)

• Adding a Pipeline in the Hierarchy (page 141)

• Moving and Renaming a Pipeline (page 144)

• Deleting a Pipeline (page 145)

• Understanding Default Location Formats (page 146)

• Selecting a Default Location Format (page 149)

• Adding a Pipeline Information Record (page 150)

• Adding a Pipeline Maintenance Record (page 154)

• Attaching a Document to a Pipeline Record (page 158)

• Working with Themes and Filter Groups (page 167)

• Filtering Data in a Grid (page 183)

Adding a Folder in the Hierarchy
The hierarchy is an organizational structure of one or more folders. Folders are organized 
in a tree structure based on the number of hierarchy levels set up in the system. The top 
level of the hierarchy is the root level that identifies your company’s name. All hierarchy 
folders are added below the root level. The lowest level of the hierarchy includes a folder 
with pipelines added in the system (Figure 4-1, page 140). 

NOTE: The names of hierarchy folders as well as ROW Code and ROW Name support up 
to 100 characters. 
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To add a folder in the hierarchy, follow these steps:

1 Click File > Select ROWs to open the Select ROWs window (Figure 4-1).

Figure 4-1.  Select ROWs

2 Select a level in the hierarchy to which you want to add a folder. 

3 Click  Add to open the Add New Node dialog box (Figure 4-2, page 140). 

NOTE: You can also open the Add New Node dialog box by right-clicking a 
selection in the hierarchy tree and selecting Add in the shortcut menu that opens.

4 Add information for the new hierarchy folder. Fields requiring information include 
a  icon, such as System and ROW Code shown in the next figure. 

5 Click the option Expand After Adding if you want to expand the selection tree 
after clicking Apply. 

6 Click  Apply. Repeat step 3 through step 5 as needed to add additional 
folders in the hierarchy tree. 

Figure 4-2.  Add New Node
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Adding a Pipeline in the Hierarchy
To add a pipeline in the hierarchy, follow these steps: 

1 If the Select ROWs window is not open, click File > Select ROWs (Figure 4-3). 

Figure 4-3.  Select ROWs

2 Select a folder in the hierarchy you want to add a pipeline. In the following 
example, another pipeline will be added in the Mains folder. 

3 Click  Add to open the Add New Node dialog box (Figure 4-4). Right-clicking 
the selected hierarchy folder and selecting Add in the shortcut menu also opens 
the Add New Node dialog box. 

Figure 4-4.  Add New Node

4 Enter a pipeline code for the new pipeline in the ROW Code field. Fields 
requiring information include a  red icon, such as ROW Code in the previous 
figure (Figure 4-4). 
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NOTE: The names of hierarchy folders as well as ROW Code and ROW Name 
support up to 100 characters. 

5 Type a name for the pipeline in the ROW Name field. 

6 Click the option Expand After Adding if you want to expand the selection tree 
after clicking Apply. 

7 Click  Apply. Repeat step 2 through step 6 as needed to add another pipeline 
in the selected hierarchy folder. 

8 Continue with Understanding Default Location Formats (page 146) for 
information about setting this required field for all pipelines in the system. 

Using Find in Select ROWs
Use the Find drop-down list in the Select ROWs window when searching for a particular 
pipeline segment in the hierarchy. The Find drop-down list includes the following options 
for locating and selecting a pipeline segment in the hierarchy: 

• Code: searches the hierarchy by ROW Code. 

• Name: searches the hierarchy by ROW Name. 

• Code and Name: searches the hierarchy by ROW Code and Name. Using this 
option requires that you include the semi-colon separator between the ROW Code 
and ROW Name, such as LG123A ; NE Paddock LG123. 
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To search the hierarchy for a particular pipeline segment in the Select ROWs window, 
follow these steps:

1 Click File > Select ROWs to open the Select ROWs window (Figure 4-5). 

Figure 4-5.  Select ROWs

2 Choose an option in the Find Now drop-down list to search for a pipeline segment 
in the hierarchy. Click the down arrow in Find ROW and select Code, Name, or 
Code and Name. 

3 Based on the selected search option, type the ROW Code, ROW Name, or the 
ROW Code and Name of the pipeline segment in the field Enter Search Text. 

4 Select one of the following options to choose how search results are handled: Find 
Only, Find and Select, Clear Selections, Find and Select. Hovering the mouse 
over an option displays a tooltip with a description of option. 

5 Click the check box Expand Display if you want PCS Axis to expand the hierarchy 
when a search match is located. 

6 Click  Find. 
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Moving and Renaming a Pipeline
Complete the following steps to move or rename a pipeline in the hierarchy: 

1 If the Select ROWs window is not open, click File > Select ROWs and then select 
a pipeline in the hierarchy (Figure 4-6). 

Figure 4-6.   Move Pipeline

2 To move the selected pipeline to a different hierarchy folder, right-click the pipeline 
and select Cut in the shortcut menu that opens. Right-click the hierarchy folder 
you want to move the pipeline to and then select Paste in the shortcut menu that 
opens (Figure 4-6). 

3 To rename the selected pipeline, follow these steps:

a Click  Rename to open the Rename dialog box (Figure 4-7). Right-clicking 
the selected pipeline and selecting Rename in the shortcut menu also opens 
the dialog box. 

Figure 4-7.  Rename Pipeline

b Type a name for the pipeline in the pipeline Code field. In the following 
example, D-1234 has been entered in the ROW Code field. Click  Save to 
apply the change and close the dialog box. 
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Deleting a Pipeline
The procedure in this section explains how to delete a pipeline in the hierarchy. Deleting a 
pipeline also deletes all facilities and history records associated with the pipeline. 

IMPORTANT: Instead of deleting a pipeline, consider creating a new hierarchy folder 
labeled Sold, Abandoned, or something similar and then moving the pipeline to that 
folder. Another option is to change the operational status of the pipeline by disabling the 
Active check box in Edit ROW Detail (Data Entry > Edit ROW Detail). Using either of these 
methods will preserve data for future references. 

To delete a pipeline, follow these steps: 

1 Click File > Select ROWs to open the Select ROWs window. Select a pipeline in 
the hierarchy you want to delete (Figure 4-8). 

Figure 4-8.  Select ROWs

2 Click  Delete to open the Confirm Delete dialog box (Figure 4-9, page 146). Or, 
right-click the selected pipeline in the hierarchy tree and select Delete in the 
shortcut menu to open the Confirm Delete dialog box. 

NOTE: The Confirm Delete dialog box identifies the pipeline and number of 
associated facilities to be deleted in the Count column (Figure 4-9, page 146). 
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3 Click  Delete to delete the pipeline or  Cancel to cancel the operation. 

Figure 4-9.  Confirm Delete

Understanding Default Location Formats
The following table (Table 4-1) identifies milepost formats available for selection when 
setting the Default Location Format for a pipeline in Edit ROW Detail. Choosing a 
Default Location Format allows PCS Axis to automatically apply the correct formatting to 
milepost values you enter for a facility location on a pipeline. 

Table 4-1.  Description of Default Location Formats

Location Format Format Example Description

Metric Milepost 1.234AB, 1,234AB, 
or 1+234AB

Measurements are in metrics. This 
format can include two alpha characters 
at the end of the milepost and can also 
be graphed. Measurements are in 
kilometers and meters. Based on the 
metric delimiter set in system Options, 
this format supports a Period, Comma, 
or Plus sign. For example, 1.234AB is 1 
kilometer (km) and 234 meters (m). 

Milepost (3 Decimals) 12345.567

-or-

1234.567AB

Format supports two alpha characters at 
the end of the milepost and can also be 
graphed. This format uses the U.S. 
Standard measurement system. 

Milepost (4 Decimals) 123.5678

-or-

1234.5678A

Format supports one alpha character at 
the end of the milepost and can also be 
graphed. This format uses the U.S. 
Standard measurement system. 
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Reading Number 12345678AB This is an alphanumeric format with 
support for two alpha characters at the 
end. It is typically used for stations. The 
format also uses the U.S. Standard 
measurement system. 

This format cannot be graphed and the 
CP Compliance Report does not 
calculate total feet, total miles, or miles 
below criteria.

Location ID 1234567891

-or-

ABCDEFGHIJ

NOTE: Location ID cannot be changed 
once it is set up. 

Use Location ID when footages are not 
applicable. This format is typically used 
in distribution systems. Other features 
include those in the following list: 

• Uses the U.S. Standard measurement 
system; accepts alphanumeric 
characters; and cannot be graphed. 

• CP Compliance Report does not 
calculate total feet, total miles, or 
miles below criteria when using this 
format. 

Station Number 12345+67AB Measurements are in feet. This format 
can be graphed; supports two alpha 
characters at the end of the milepost; 
and uses the U.S. Standard 
measurement system. 

Table 4-1.  Description of Default Location Formats

Location Format Format Example Description
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Miles+100 Feet 12345+12

-or-

12345+12AB

Format uses miles plus two digits to the 
right to indicate hundreds of feet. For 
example, 110+12 indicates 110 miles 
and 1,200 feet. Do not enter values 
greater than 53 feet; doing so indicates 
another mile.

Other characteristics include:

• Format can be graphed.

• Two alpha characters can be used 
after the first 3 numbers.

• CP Compliance Report does not 
calculate total feet, total miles, or 
miles below criteria. 

• Uses the U.S. Standard 
measurement system.

Miles/Station Number 123A 45+67

-or-

123A 12+34

Format uses Miles<space>Station 
Number with Milepost (3 Decimals) in 
graphs. This format uses the U.S. 
Standard measurement system.

Table 4-1.  Description of Default Location Formats

Location Format Format Example Description
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Selecting a Default Location Format
Information in this section explains how to set up Default Location Format and other 
pipeline information. A Default Location Format must be set for each pipeline added in 
the system hierarchy. 

Complete the following steps:

1 Click File > Select ROWs to open the Select ROWs window (Figure 4-10).

Figure 4-10.  Select ROWs

2 Select one or more pipelines and then click  Save to close the window. 

3 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-11, page 149). 

Figure 4-11.  Edit ROW Detail

Click the Selected ROWs 
bar to expand and collapse 
the Selected ROWs panel. 
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4 If you want to collapse the Selected ROWs panel to view more of the Edit ROW 
Detail grid, click Selected ROWs. To expand the panel, click Selected ROWs 
again. 

5 Select a pipeline in the Information grid. 

6 Select the field Default Location Format to display a drop down arrow. Click the 
arrow and select a location format in the selection list. (See Understanding 
Default Location Formats (page 146) for a description of available choices.)

7 Click  Add in the Facility Location ID Formats mini-grid. A list of all facility 
types display in the mini-grid with the location format selected in step 6. If you 
want to change the location format for a particular facility type listed in the mini-
grid, follow these steps:

a Select a row of records in the mini-grid with the facility type you want to 
change the location format. 

b Select the field Facility Location Format to display a drop down arrow. Click 
the arrow and select a location format in the selection list. 

8 Set up other pipeline information as needed then click  Refresh. When you 
finish, click the  close icon to close the Edit ROW Detail window. 

Adding a Pipeline Information Record
Use the Information grid in Edit ROW Detail to add an information record for a pipeline 
selected in the Select ROWs window. Adding an information record allows you to maintain 
history records when important permanent information changes, such as when a pipeline 
is taken out of service or is sold to another business. 

NOTE: If you are working with the optional Telluric Compensation feature, the required 
field labeled Telluric Compensation Required must be added in the Information grid and 
enabled for each pipeline segment requiring telluric compensation. For more information 
refer to Adding a Layout Theme (page 168). 

To add a pipeline information record, follow these steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 4-12). 
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Figure 4-12.  Select ROWs

2 Select one or more pipeline segments you want to work with by clicking the check 
box for each pipeline segment. Click  Save to close the window. 

NOTE:  A check mark inside a check box indicates a selection. To clear a selection, 
click the check box again to remove the check mark. A shaded check box indicates 
selection of some, not all, child folders, ROWs, and pipelines. 

3 Open the Edit ROW Detail grid. Click Data Entry > Edit ROW Detail (Figure 4-
13). 

Figure 4-13.  ROW Detail Information Grid
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4 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

5 If the Information grid is not visible, click the Information tab . 

6 Click  Add to open the Add Record dialog box (Figure 4-14). 

HINT: Alternatively, you can use a keyboard shortcut key to add records. Press F4 
to add an information record for an existing pipeline in the grid.

Figure 4-14.  Add Record
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7 Select the pipeline in the dialog box that you want to add an information record. 
For example, pipeline IS-0767-01 is selected in Figure 4-14. 

8 Click  Save to display required field(s) for data entry (Figure 4-15). 

Figure 4-15.  Add Record

9 Type a date in the Effective Date field using the format MM/DD/YYYY to indicate 
the month, day, and year. Or click the down arrow in the field and select a date 
using a calendar. 

Effective Date is the date a history record becomes effective, such as when a 
pipeline becomes inactive or is taken out of service. See Creating History Records 
Using an Effective Date (page 245) for more information. 

10 Click  Save to close the Add Record dialog box and add the new information 
record in the grid for the existing pipeline (Figure 4-15). 
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Figure 4-16.  ROW Detail Information Grid - New Record

11 Provide other pipeline data in the grid as needed, such as Permanent Comments. 

12 Click  Refresh to update the grid. 

Adding a Pipeline Maintenance Record
Use the Maintenance grid in Edit ROW Detail to add a maintenance record for a pipeline 
selected in the Select ROWs window. Adding pipeline maintenance records allows you to 
examine the effectiveness of a maintenance program. You can either view data in the 
maintenance grid of Edit ROW Detail or run a ROW maintenance report. 

To add a pipeline maintenance record, follow these steps: 

1 Click the Select ROWs button  to open the Select ROWs window (Figure 4-12, 
page 151). Select one or more pipeline segments you want to work with by clicking 
the check box for each pipeline segment. Then click  Save to close the window. 

2 Open Edit ROW Detail. Click Data Entry > Edit ROW Detail (Figure 4-17). 
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Figure 4-17.  Row Detail Information Grid

3 If you want to collapse the Selected ROWs panel to view more of the grid, click the 
Selected ROWs bar. Clicking the bar again expands the panel.

4 Click the Maintenance tab  to open the Maintenance grid (Figure 4-
17).

 

Figure 4-18.  ROW Detail Maintenance Grid

5 Click  Add to open the Add Record dialog box (Figure 4-14). 

HINT: Alternatively, you can use a keyboard shortcut key to add records. Press F4 
to add a maintenance record for an existing pipeline in the grid.
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Figure 4-19.  Add Record

6 Select the pipeline in the dialog box that you want to add an information record. 
For example, pipeline IS-0767-01 is selected in Figure 4-14. 

7 Click  Save to display required field(s) for data entry (Figure 4-15). Required 
fields are identified with the  icon, such as ROW Repair Code.

Figure 4-20.  Add Record

8 Type a repair code in the field ROW Repair Code. Repair code is a designation 
used by your company to identify the type of repair. The field accepts up to 15 
alphanumeric characters including special characters such as the pound sign (#), 
asterisk (*), or hyphen (-). 

9 Type a date in the field ROW Repair Found Date using the format MM/DD/YYYY 
to indicate the month, day, and year. Or click the down arrow in the field and select 
a date using a calendar. 
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Figure 4-21.  Add Record

10 Click  Save to close the Add Record dialog box and add a pipeline maintenance 
record in the grid (Figure 4-22). 

11 Provide other maintenance data in the grid as needed. For example, provide a date 
in the fields ROW Repair Initiated Date and ROW Repair Corrected Date; a 
maintenance reference number in the field ROW Reference Number ; and remarks 
about the repair in the field ROW Repair Remarks. 

12 Click  Refresh to update the grid. 

Figure 4-22.  ROW Detail Maintenance Grid - New Record
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Attaching a Document to a Pipeline Record
Attaching a document to a pipeline record in Edit ROW Details is similar to attaching a 
document to a record in a data entry grid. Use the Attached Document field in the 
Information and Maintenance grid of Edit ROW Details to link or embed a file or 
webpage address to a pipeline record. Supported file types include image, video, HTML, 
XML, music, and text files (such as Microsoft Word, WordPad, Notepad, or PowerPoint 
files). 

As an example, you can attach an image of a pipeline; a document describing your 
company’s safety procedures; or a document identifying a manufacturer’s specification for 
a piece of equipment. 

Linking a document identifies the file location on a local computer, company network, FTP 
site, or webpage on the Internet. Linking documents stored on a local computer are 
accessible only from that computer. Embedding a document stores a copy of the file in the 
PCS Axis database. 

NOTE: Storing copies of documents in the PCS Axis database increases the size of the 
database. 

If the file type of an attached document is associated with a default software program on 
the local computer, you can preview the file in the Preview Attached Documents window. 
Additionally, clicking Open opens the attached document for editing or viewing purposes. 

Editing an embedded document applies changes only to the copy stored in the PCS Axis 
database; changes do not apply to the source file stored outside of PCS Axis. Likewise, 
editing a source file applies changes only to the source file, not the copy stored in PCS 
Axis. 

Topics in this section include those in the following list:

• Adding the Attached Document Field in the Grid

• Attaching a Document to a Pipeline Record (page 160)

• Viewing an Attached Document (page 165)

NOTE: For information about how to attach a document to a record in a data entry 
grid, Using Data Entry Grids and Forms (page 221). 
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Adding the Attached Document Field in the Grid
If the Attached Document field is not present in the Information or Maintenance grid of 
Edit ROW Details, complete the following steps to add the field: 

1 Select one or more pipeline segments you want to work with in the Select ROWs 
window. Click  Save to close the window. 

2 Click Data Entry > Edit ROW Details to open the Edit ROW Detail window 
(Figure 4-23). 

Figure 4-23.  Edit ROW Detail

3 If you want to collapse the Selected ROWs panel to view more of the Edit ROW 
Detail grid, click Selected ROWs. To expand the panel, click Selected ROWs 
again (Figure 4-23, page 159). 

4 Based on the grid you want to add the Attached Document field, click the 
Information  or Maintenance  tab if either of these grids is 
not visible. 

5 Click the Customize tab  to view the Layouts page (Figure 4-24, 
page 160). 

6 Choose a grid layout theme. Click the down arrow in Select Layout Theme and 
select a layout theme in the selection list. 

7 Double-click  All Fields in the left pane of the window to view a list of fields 
available for selection. 
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8 Add the field ROW Attached Documents in the layout theme. Double-click ROW 
Attached Documents in the left pane of the Layouts page to move it to the right 
pane. Add other fields as required. The layout theme includes all fields listed in the 
right pane (Figure 4-24). 

9 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the  up or  down button. 

10 Click  Save and Close to save changes and return to the grid. 

Figure 4-24.  Layouts

Attaching a Document to a Pipeline Record
Complete the following steps to attach a document to a pipeline record in the 
Information or Maintenance grid of Edit ROW Detail: 

1 Select one or more pipeline segments you want to work with in the Select ROWs 
window. Click  Save to close the window. 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-25). 

3 If you want to collapse the Selected ROWs panel to view more of the Edit ROW 
Detail grid, click Selected ROWs. To expand the panel, click Selected ROWs 
again. 
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4 If you want to attach a document to a pipeline record in the Information grid, click 
the Information tab if the grid is not visible. 

To attach a document to a pipeline record in the Maintenance grid, click the 
Maintenance tab to display the Maintenance grid. 

5 Click the edit icon  in the ROW Attached Document field for the pipeline 
record you plan to attach a document (Figure 4-25). 

Figure 4-25.  Edit ROW Detail 

6 When the Maintain Attached Documents dialog box opens, click  Attach and 
then select one of the following options (Figure 4-26, page 162):

• Link Document: Select Link Document if you plan to link to a document on 
a local computer or company network, or want to add a link to a webpage on 
the Internet. Then continue with step 7 (page 162) or step 8 (page 163). 

• Embedded Document: Select Embedded Document if you want to store a 
copy of an attached document in the PCS Axis database. Then continue with 
step 9 (page 164). 

NOTE: Storing copies of attached documents in the database increases the 
size of the database. 
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7 If you selected Link Document in step 6 and want to link to a file on a local 
computer or company network, follow these steps (Figure 4-26): 

a Click the ellipsis button … in the Document field to open the Link File dialog 
box. Then navigate to the file and select it. Click Open to link to the file and 
close the dialog box. 

b Type a description for the linked file in the Description field of the Maintain 
Attached Documents dialog box. When a description is not provided, PCS 
Axis uses the filename of the linked document as the description. 

NOTE: A list of attached documents display in the dialog box. Selecting an 
item in the list displays its location in the Document field. 

Figure 4-26.  Maintain Attached Documents

c Click  Save and Close to save changes and close the dialog box. When the 
following message displays click  OK:

Linked Document won’t be replicated. Do you want to continue? 

NOTE: Linked documents are not copied and stored in the PCS Axis database 
as noted in the previous message. To store a copy of an attached document in 
the database, use the Embedded Document option instead. 
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8 If you selected Link Document in step 6 and want to add a link to a webpage on 
the Internet, follow these steps (Figure 4-27): 

a Type an Internet address in the Document field. For example, type 
http://www.aiworldwide.com in the field. 

b Type a description for the link in the Description field. When a description is 
not provided, PCS Axis uses the Internet address in the Document field as the 
description. 

Figure 4-27.  Maintain Attached Documents

c Click  Save and Close to save changes and close the dialog box. When the 
following message displays click  OK:

Linked Document won’t be replicated. Do you want to continue? 

NOTE: Linked documents are not copied and stored in the PCS Axis database 
as noted in the previous message. To store a copy of an attached document in 
the database, use the Embedded Document option instead. 
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9 If you selected Embedded Document in step 6, complete the following steps 
(Figure 4-28):

a Click the ellipsis button … in the Document field to open the Embed File 
dialog box. Then navigate to the file and select it. Click Open to embed a copy 
of the file and close the dialog box. 

b Type a description for the embedded file in the Description field. If a 
description is not provided, PCS Axis uses the filename of the embedded file 
as the description. 

NOTE: A list of attached documents display in the dialog box. Selecting an 
item in the list displays its location in the Document field. 

Figure 4-28.  Embedded Document

c Click  Save and Close to save changes and close the dialog box. When the 
following message displays click  OK:

Local changes made to embedded documents won’t be saved into PCS. 
Do you want to continue? 

NOTE: Editing an embedded document applies changes only to the copy 
stored in the PCS Axis database; changes do not apply to the source file stored 
outside of PCS Axis. Likewise, editing a source file applies changes only to the 
source file, not the copy stored in PCS Axis. 
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Viewing an Attached Document
If the file type of an attached document is associated with a default software program on 
the local computer, you can preview the file in the Preview Attached Documents window. 
Additionally, clicking Open opens the attached document for editing or viewing purposes. 

To view or open an attached document, follow these steps:

1 Select one or more pipeline segments you want to work with in the Select ROWs 
window. Click  Save to close the window. 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-29). 

3 If you want to collapse the Selected ROWs panel to view more of the Edit ROW 
Detail grid, click Selected ROWs. To expand the panel, click Selected ROWs 
again. 

4 Open the grid that includes the pipeline record with the attached document by 
clicking either the Information  or Maintenance  tab.

5 Click the preview icon  for the pipeline record with the attached document you 
want to view. 

Figure 4-29.  Edit ROW Detail
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6 Select a file in the list on the left side of the window to view the file in the Preview 
Attached Documents window (Figure 4-30). 

7 If the file type of the attached document is associated with a default software 
program on the local computer, click  Open to open the file. 

8 Click the close button  to close the Preview Attached Documents window.

NOTE: When you open and then edit an embedded document, changes apply 
only to the copy stored in the PCS Axis database; changes do not apply to the 
source file stored outside of PCS Axis. Likewise, editing the source file applies 
changes to the source file, not the copy stored in the PCS Axis database. 

Figure 4-30.  Preview Attached Documents
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Working with Themes and Filter Groups
A theme is a group of named settings saved for later use, such as grid layout or sort 
theme. Themes are either public or private. A public theme is available for use by all PCS 
Axis users. A private theme is available only to the user who creates it. 

Several installed themes are provided with the PCS Axis software installation. PCS Axis 
installed themes are public themes available to all PCS Axis users. These themes are 
identified with a globe icon and PCS in brackets [PCS], such as  [PCS] ROW 
Information. 

NOTE: Only public themes for layouts, sorts, and reports are available for selection. If you 
would like to use a private theme, your company’s system administrator must make your 
private theme a public one.

A filter group is a named set of one or more filters that affect the data output in the Edit 
ROW Detail grid. PCS Axis provides two types of filter groups you can define. These 
include the AND and OR filter groups. 

When you add a filter group, you define filter conditions that determine which records to 
include or exclude in the Edit ROW Detail grid. Adding an AND filter group produces a 
subset of records that meet all filter conditions. Adding an OR filter group produces a 
subset of records that meet any filter condition. When you apply a filter group to the grid, 
PCS Axis processes filters in descending order beginning with the filter at the top of the 
group. 

The following sections describe how to add a layout theme, sort theme, and an optional 
filter group in the Information and Maintenance grids of Edit ROW Detail. Topics include 
those in the following list: 

• Adding a Layout Theme

• Adding a Sort Theme (page 172)

• Adding an AND Filter Group (page 175)

• Adding an OR Filter Group (page 178)

• Editing and Arranging Filters and Filter Groups (page 180)

NOTE: Also see Filtering Data in a Grid (page 183) for information about 
filtering the data output in a data entry grid. 
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Adding a Layout Theme
A layout theme is a group of fields that determine which fields are available for use in the 
Information and Maintenance data grid of Edit ROW Detail. Adding a new Layouts 
theme allows you to choose which fields to include in the data grid and then save the 
layout as a theme for later use. 

IMPORTANT: If you are working with the optional Telluric Compensation feature, you can 
add a layout theme that includes the required field Telluric Compensation Required. This 
field must be enabled in the Information data grid of Edit ROW Detail for each pipeline 
segment requiring telluric compensation. 

To add a layout theme for the Information or Maintenance data entry grid in Edit ROW 
Detail, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31). 

Figure 4-31.  Select ROWs

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window. If you 
want to collapse the Selected ROWs panel to view more of the Edit ROW Detail 
grid, click Selected ROWs. To expand the panel, click Selected ROWs again 
(Figure 4-32, page 169). 

3 To add a layout theme for the Information grid, click the Information tab 
 if the grid is not visible. Click the Maintenance tab  to 

display the Maintenance grid if you want to create a layout theme for this grid. 
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Figure 4-32.  Edit ROW Detail

4 Click the Customize tab  then  Add to open the New Layout Theme 
dialog box. The following figure shows an example when adding a layout for the 
Information grid (Figure 4-33). 

Figure 4-33.  New Layout Theme

5 Type a name for the layout theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it. 
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6 Select a layout theme with fields you want to copy to the new layout theme. Click 
the Copy Content check box and then click the down arrow in Copy Fields From 
Theme and select a theme in the selection list. 

7 Click  OK to save changes and return to the Layouts page (Figure 4-34). 

Figure 4-34.  Layouts

8 Complete the following steps in the Layouts page to add and remove fields in the 
new layout theme as needed:

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The grid layout theme includes all fields listed in the right 
pane of the Layouts page. 

c If telluric compensation is required for the selected pipeline segment(s), add 
the field labeled Telluric Compensation Required in the layout theme. 

d To remove a field in the layout theme, double-click a field listed in the right 
pane to move it to the left pane. Repeat this step as needed. 

NOTE: Fields with a lock icon  are required and cannot be removed from the 
theme, such as  ROW Code shown in the previous example (Figure 4-34, 
page 170). 
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9 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the  up or  down button. 

10 Click  Save to save changes. 

11 To apply the new layout theme to the data entry grid: 

a Click the Options tab  to open the options page (Figure 4-35). 

b Click the down arrow in the field Select Layout Theme and select the new 
layout theme in the selection list. 

c Click  Apply to save changes and return to the data entry grid. 

Figure 4-35.  Options

12 If telluric compensation is required for the selected pipeline segment(s), click the 
Telluric Compensation Required check box for each pipeline segment requiring 
compensation. 

A check mark inside the check box indicates the option is enabled. To disable the 
option, click the check box again to remove the check mark. 
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Adding a Sort Theme
A sort theme determines how PCS Axis sorts records in a data entry grid. Adding a sort 
theme allows you to choose which field(s) to sort records by and if records sort 
alphanumerically in ascending or descending order. 

To add a sort theme, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31, page 168). 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-32, page 169).

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

3 To add a sort theme for the Information grid, click the Information tab 
 if the grid is not visible. Click the Maintenance tab  to 

display the Maintenance grid if you want to create a sort theme for this grid. 

4 Click the Customize tab  then the Sorts button  to open 
the Sorts page (Figure 4-36). 

Figure 4-36.  Sorts
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5  Click  Add to open the New Sort Layout dialog box (Figure 4-37). 

Figure 4-37.  New Sort Layout

6 Type a name for the sort theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the sort theme saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it. 

7 Select a sort theme with fields you want to copy to the new sort theme. Click the 
down arrow in Copy Fields From Theme and select a theme in the selection list. 

8 Click  OK to save changes and return to the Sorts page (Figure 4-38, page 174). 

9 Complete the following steps in the Sorts page to add and remove fields in the 
new sorting theme as needed: 

a Click the toggle arrow  for a field category in the left pane of the window to 
view a list of fields available for selection. For example, click  All Fields. 

b Double-click a field listed in the left pane to move it to the right pane. Repeat 
this step as needed. The sorting theme includes all fields listed in the right 
pane. 

c If you want to remove a field in the sorting theme, double-click a field listed in 
the right pane to move it to the left pane. Repeat this step as needed. 
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10 Select a sorting method for each field listed in the right pane. To sort grid records 
in ascending order, click the toggle button to select ASC . To sort in 
descending order, click the toggle button to select DESC .

11 To change the order of fields listed in the right pane and subsequently in the grid, 
click and drag a field to a new position in the list. Or, select a field and then click 
the up  or down  button. 

Figure 4-38.  Sorts

12 Click  Save to save changes.

13 To apply the new sort theme to the data entry grid, follow these steps: 

a Click the Options tab  to open the options page (Figure 4-39, 
page 175). 

b Click the down arrow in the field Select Sort Theme and select the new sort 
theme in the selection list. 

c Click  Apply to save and apply changes and then return to the data entry 
grid. To cancel changes, click the Options tab  or  Cancel to return 
to the grid. 
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Figure 4-39.  Options

Adding an AND Filter Group
An AND filter group is a named set of one or more filters that affect the data output in the 
Edit ROW Detail grid. Adding an AND filter group produces a subset of records that meet 
all filter conditions. PCS Axis processes filters in a filter group in descending order 
beginning with the filter at the top of the filter group. 

To add an AND filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31, page 168). 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-32, page 169). 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

3 Select the grid you want to work with by clicking the Information tab  
or the Maintenance tab . 

4 Click the Customize tab  then the Filters button  to open 
the Filters page (Figure 4-40, page 176). 

5 Click  New ‘And’ Group to open the filter properties group box. 
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Figure 4-40.  Filters

6 Type a name for the filter group in the field Filter Group Caption. 

7 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

8 If you want the filter to remain on for all sessions of the data entry grid, select the 
check box Filter is Always On. When this check box is not selected, toggle the 
filter on and off in the Options page using the filter’s check box. 

9 Type a name for the filter in the field Enter Custom Filter Caption. 

10 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. Then click the 
 edit icon to display selection fields. 

b Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat step 7 through step 9 to set up filter criteria. 

11 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 
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12 Click  Save. 

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 

13 To apply one or more custom filter groups to the data entry grid of Edit ROW 
Detail, follow these steps (Figure 4-41, page 177):

a Click the Options tab  to open the options page. 

b Click the check box for each filter you want to apply. 

c Click  Apply to save changes and return to the data entry grid. To cancel 
changes, click the Options tab  or  Cancel to return to the data 
entry grid. 

Figure 4-41.  Options
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Adding an OR Filter Group
An OR filter group is a named set of one or more filters that affect the data output of a 
report. Adding an OR filter group produces a subset of records that meet any filter 
condition. PCS Axis processes filters in a filter group in descending order beginning with 
the filter at the top of the filter group. 

To add an OR filter group, follow these steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31, page 168). 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-32, page 169). 

NOTE: Clicking the Selected ROWs bar collapses the Selected ROWs panel 
allowing you to view more of the grid. Clicking the Selected ROWs bar again 
expands the Selected ROWs panel. 

3 Select the grid you want to work with by clicking the Information tab  
or the Maintenance tab . 

4 Click the Customize tab  then the Filters button  to open 
the Filters page (Figure 4-42). 

5 Click  New ‘Or’ Group to open the filter properties group box. 

Figure 4-42.  Filters
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6 Type a name for the filter group in the field Include records that match any of 
these conditions (Figure 4-42, page 178). 

7 Use filter selection fields to set up filter criteria. Select a PCS Axis field, operator, 
and one or more filter conditions. 

8 If you want the filter to remain on for all sessions of the data entry grid, select the 
check box Filter is Always On. When this check box is not selected, toggle the 
filter on and off in the Options page using the filter’s check box. 

9 Type a name for the filter in the field Enter Custom Filter Caption. 

10 If you want to set up additional filter criteria for the filter group:

a Click  Add to open another filter properties group box. 

b Type a name for the filter in the field Enter Custom Filter Caption. Then 
repeat step 7 and step 8 to set up filter criteria. 

11 To move a filter to a different position in the filter group or a filter group to a 
different position in a group of filters:

a Point the mouse at the filter handle  to change the cursor to a vertical resize 
cursor . 

b Drag and drop the filter or the filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

12 Click  Save.

NOTE: Clicking the  edit icon for a particular filter opens that filter’s property 
settings allowing you to change settings as needed. 

13 To apply one or more custom filter groups to the data entry grid of Edit ROW 
Detail, follow these steps (Figure 4-43, page 180):

a Click the Options tab  to open the options page. 
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b Click the check box for each filter you want to apply. 

c Click  Apply to save changes and return to the data entry grid. To cancel 
changes, click the Options tab  or  Cancel to return to the data 
entry grid. 

Figure 4-43.  Options

Editing and Arranging Filters and Filter Groups
PCS Axis processes filters in a filter group in descending order beginning with the filter at 
the top of the filter group. Filter groups are processed similarly. Information in this section 
explains how to edit filter property settings and how to arrange filters and filter groups. 

Complete the following steps: 

1 Select one or more pipeline segments in the Select ROWs window. Click  Save 
to close the window (Figure 4-31, page 168). 

2 Click Data Entry > Edit ROW Detail to open the Edit ROW Detail window 
(Figure 4-32, page 169). 

3 Select the grid you want to work with by clicking the Information tab  
or the Maintenance tab . 
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4 Click the Customize tab  then the Filters button  to open 
the Filters page (Figure 4-44). 

5 Click the edit icon  to display a filter’s property settings.

Figure 4-44.  Filters

6 To delete a filter in a filter group, click the filter’s  delete button (Figure 4-
45). Then click  Yes when the Delete message displays. 

7 To rename a filter, type a description in the filter’s name field. 

8 To change filter criteria, use filter selection fields to select a PCS Axis field, 
operator, and one or more filter conditions. 

9 To enable a filter for all sessions of the data entry grid, click the check box Filter is 
Always On to place a check mark inside the check box. When this check box is not 
selected, toggle the filter on and off in the options page using the filter’s check 
box. 

10 Click the  close button to close the filter’s property settings group box. 
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11 To move a filter to a different position in a filter group, or to move a filter group to 
a different position, follow these steps: 

a Point the mouse at the handle  of a filter or filter group to display a vertical 
resize cursor . 

b Drag and drop the filter or filter group to a new location. 

NOTE: PCS Axis processes filters in descending order beginning with the filter 
at the top of the filter group. 

12 Click  Save and Close to save changes and return to the data entry grid. 

Figure 4-45.  Filters
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Filtering Data in a Grid
Information in this section explains how to filter the data output in any data entry grid in 
Edit ROW Detail. It includes a description of the options and filters available in the 
Options page when working with the Information and Maintenance grids. Filtering data 
allows you to work with only those records you are interested seeing in the grid. 

Topics in this section include those in the following list:

• Filtering Data in the Information Grid

• Filtering Data in the Maintenance Grid (page 184)

Filtering Data in the Information Grid
To filter the data output in the Information grid of Edit ROW Detail, follow these steps: 

1 Click Data Entry > Edit ROW Detail. 

2 Click the Information tab , then the Options tab  to open the 
Options page (Figure 4-46). 

Figure 4-46.  Options/Information Grid
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3 To include only the most recent information record for each pipeline, select the 
check box Only the most recent information record for each facility. This 
option uses the Effective Date to filter the data output. 

NOTE: When using the Filters group box to apply additional filters to the data 
output, the most recent information record is found first, and then all other filters 
are applied to the data output. For more information about filters, see Adding an 
AND Filter Group (page 175) and Adding an OR Filter Group (page 178). 

4 Click  Apply to save and apply changes and then return to the Information 
grid. To cancel changes, click the Options tab  or  Cancel to return to 
the grid. 

Filtering Data in the Maintenance Grid
To filter the data output in the Maintenance grid of Edit ROW Detail, follow these steps: 

1 Click Data Entry > Edit ROW Detail. 

2 Click the Maintenance tab , then the Options tab  to open the 
Options page (Figure 4-47). 

Figure 4-47.  Options/Maintenance Grid
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3 Review the following descriptions and then select one or more filter options as 
required:

• Only include facilities with maintenance during the reporting time 
period: The data output for this option only includes those maintenance 
records that meet the filter criteria defined for a particular date or date 
range. Filter criteria is defined by filter settings in the Filters group box for 
any of the following time period fields: Effective Date, Repair Found Date, 
Repair Initiated Date, and Repair Corrected Date. 

• All maintenance that meet the filter criteria: This option includes all 
maintenance records in the data output that meet filter criteria based on filter 
settings in the Filters group box. 

• Apply other filters to the most recent maintenance found within the report 
timeframe: This option finds the most recent maintenance record within the 
reporting time frame first, and then applies other filter settings to the data 
output. Filter criteria for both of these are defined in the Filters group box. 
Use any of the following fields when defining filter criteria for the reporting 
time frame: Effective Date, Repair Found, Repair Initiated, and Repair 
Complete.

• The most recent maintenance after the filter criteria has been met: The 
data output for this option includes the most recent maintenance record only 
for those pipeline records that meet all other filter criteria first. Filter criteria 
for both of these are defined in the Filters group box. Use any of the following 
fields when defining a time period for the most recent maintenance record:
Effective Date, Repair Found, Repair Initiated, and Repair Complete.

NOTE: For more information about filters, see Working with Themes and 
Filter Groups (page 167). 

4 Click  Apply to save and apply changes and then return to the Maintenance 
grid. To cancel changes, click the Options tab  or  Cancel to return to 
the grid. 
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