
Setting Up PCS Axis

PCS Axis modules share a common interface and many similar functions. Information in 
this section explains how to set up features common to all PCS Axis modules. 

If you are unable to access a PCS Axis menu or perform a particular function, check with 
your system administrator to verify your PCS Axis user account is set up with an 
appropriate user role in User Management (see Setting Up User Management). 

Topics in this section include those in the following list:

• Preparing to Set Up PCS Axis (page 29)

• Understanding a Typical PCS Axis Workflow (page 32)

• Understanding the System Hierarchy (page 33)

• Setting the System Hierarchy (page 34)

• Setting Up PCS Axis (page 36)

• Working with Custom Security Roles (page 57)

• Working with Pipeline Series (page 121) 

• Working with a User Defined Module (page 128)

Preparing to Set Up PCS Axis
After installing PCS Axis, consider the following questions before you begin setting up PCS 
Axis for operation. Answers to these questions determine how you set up PCS Axis to fit 
your company's business needs. 

Question: How is your company's pipeline system organized?

Pipeline companies organize their distribution or transmission pipeline system using 
certain terms to describe how the system is organized. For example, terms such as 
Right-of-way (ROW), Pipeline Segment, Section, Section Map, District, County, Region, 
or State may be used. 

Setting up PCS Axis for operation requires that you define a pipeline system hierarchy. 
PCS Axis supports up to five (5) hierarchy levels and can be organized and named in 
the same manner as your company's pipeline system. 
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Question: How does your company identify inspection points on a pipeline? 

A location name and location format must be set up for inspection points on a pipeline 
before users begin entering survey data in PCS Axis. Once this information has been 
established, it is recommended that you do not change it in order to maintain data 
integrity. 

When you first install PCS Axis, default settings for location name and location format 
are Milepost and Station Number respectively. However you can change both of these 
to match your company's method for identifying inspection points on a pipeline. 

Question: What is your company's policy for scheduling surveys? 

Default settings in PCS Axis for survey schedules and grace periods are based on 
current regulations. You can however edit these default settings to match your 
company's survey policies instead. 

For example, the grace period for surveying long lines is three months. However your 
company's policy may be less than three months. When setting up PCS Axis survey 
schedules, enter your company's grace period to ensure surveys are scheduled 
correctly. 

Question: Does your company want to use PCS Axis security features? 

The User Management feature in PCS Axis controls system security using a role based 
method. Each PCS Axis user is assigned a user role. Users with SysAdmin security 
permissions have full control of the hierarchy and all system features. Users with User 
or Read Only security permissions have limited control. 

For a list of user role permissions assigned to the User and Read Only user roles, see 
System Security. 

Question: Will your company need unique data recorded in PCS Axis? 

Although PCS Axis provides many fields for entering data, you can create what is called 
a User-Defined Field (UDF) when a PCS Axis field does not exist. Your company's data 
collection forms are a good place to gather data for a UDF you may want to create. 

For example, if test points are identified by map numbers, create a UDF to be used for 
data entry of test point map numbers. 

Question: Will PCS Axis themes need to be customized to fit your company's business 
needs? 

PCS Axis uses themes for many operations, such as themes for data entry grids, sorting 
methods, filtering data, and field computer prompts. The PCS Axis software installation 
includes several installed themes ready for use. 
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You can modify PCS Axis installed themes and also add new themes to include only 
those features that fit your business needs. For example, you might want to include 
specific data fields for entering and viewing a particular type of survey data. 

Question: Do you want to set up picklists that allow users to choose from a list of 
acceptable choices when entering survey data? 

When a data entry field is limited to certain data, consider creating a picklist that 
includes only those items for selection, such as repair codes, priority levels, or status 
conditions. 

For example, you may want to create a picklist with items for selection that identify 
insulator status as good, missing, and shorted. Picklists are helpful in reducing data 
entry errors by allowing users to select an item from a list of approved choices instead 
of entering data manually. 

Related Topics

• Understanding a Typical PCS Axis Workflow

• Understanding the System Hierarchy

• Setting the System Hierarchy

• Setting Options

• Setting Properties in Field and UDF Customizations

• Choosing a Printer for PCS Axis
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Understanding a Typical PCS Axis Workflow
A typical workflow for working in PCS Axis is shown in Figure 3-1. Some operations are 
required and only occur once when setting up PCS Axis, such as setting up system Options 
and Edit ROW Detail identified in the following figure. Others may occur more often as 
needed by PCS Axis users with appropriate security permissions, such as adding or moving 
pipeline segments in the hierarchy; adding survey folders; customizing themes and 
reports; or creating routes and schedules for facility survey inspections. 

Figure 3-1.  Typical PCS Axis Workflow

1 Set Up PCS Axis

Edit System Options1.
(Company Name, Hierarchy Levels, & 
User Location Name are required.)

Edit ROW Detail3.

Edit Survey Folders4.

Edit User Management5.

(User Location Format is required.)

Edit ROWs2.
(Add, move, & rename pipeline segments 
in Select ROWs as needed.)

Create Custom Security Roles
(optional)

Edit Themes

Edit Field & UDF Customizations

Edit Routes & Schedules

Edit Themes Management & 
Facility Types Management

(Includes Field Captions, UDFs, 
Picklists, etc., as needed.)

2 Customize Features

3

Manual Data Entry

Bridge, Bridge with Bullhorn 
Integration (optional)

Transfer from Allegro Field PC 
(optional)

Survey data via:

Enter Survey Data

4

Reports

Graphs

Set up and run:

Set Up/Run Reports
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Understanding the System Hierarchy
Before you begin entering data in PCS Axis, you first need to establish the system 
hierarchy and enter your company’s name. The hierarchy determines how PCS Axis 
organizes data. The company name displays at the top of all reports and graphs. 

You can create a hierarchy that reflects how your company categorizes its pipeline system. 
For example, you may want to create a hierarchy based on one or more of the following 
criteria: division, district, county, region, system, right-of-way (ROW), or section map. 

PCS Axis supports a hierarchy structure with up to 5 levels. The top hierarchy level includes 
either your company’s name or other type of descriptor. Figure 3-2 shows a hierarchy 
structure with 3 hierarchy levels. The names of hierarchy folders as well as ROW Code and 
ROW name support up to 100 characters. 

IMPORTANT: It is recommended that you do not change the hierarchy structure after 
entering data in the database. 

Figure 3-2.  Example of Hierarchy Structure

1 Company Name 

Level 3 Hierarchy (Region)2

Level 2 Hierarchy (System)3

Level 1 Hierarchy (Pipeline)4

1
2

4
3
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Setting the System Hierarchy
This procedure explains how to set up PCS Axis with the following required system 
settings: your company’s name, the number of levels in the system hierarchy, and a name 
for inspection points on a pipeline. A Public caption in this Options screen indicates the 
associated property setting applies globally to all users and can only be changed by a 
SysAdmin. 

The required setting User Location Format in Edit ROW Details will not be completed 
during the initial system set up. After adding pipeline records in the system hierarchy, the 
User Location Format can be configured for each pipeline record to identify how 
inspection points are located on a pipeline. For more information, see Understanding 
Default Location Formats (page 146). 

To create the system hierarchy, follow these steps:

1 Click Tools > Options > General to open the General options page (Figure 3-3). 

2 Type the name of your company in the field Company Name. 

3 Identify how your company refers to inspection points on a pipeline. For example, 
type Milepost, Station Number, Reference Reading, or other type of descriptor in 
the field User Location Name. 

Figure 3-3.  Company Name and User Location Name
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4 Click the Hierarchy tab to open hierarchy options page (Figure 3-4).

5 Click the check box Hide Parallel Lines if you want to hide features in PCS Axis 
that allow you to create and display parallel lines in the hierarchy. 

NOTE: When Hide Parallel Lines is enabled, parallel lines are hidden in Select 
ROWs and in the Add New Node dialog box. Distribution companies with no 
parallel lines typically use this setting. PCS Axis identifies parallel lines using the 
fields Pipe, Pipeline Code, and Pipeline Name. For a description of these fields 
refer to System Field Descriptions on page 811. 

6 Identify how many levels to include in the hierarchy. Click the down arrow in the 
Levels field and select the number of hierarchy levels in the selection list.  

7 Identify how pipelines are referred to in the system. For example, type ROW or 
Segment in the Level 1 field. 

8 Type a description for each additional level in the hierarchy using the fields labeled 
Level 2 through Level 5 as required. 

9 (SysAdmin only) For property settings accompanied by a Private check box, check 
or uncheck the check box based on your company’s requirements. When the 
Private check box is checked, the currently logged in user can change the 
associated property setting. For more information, see Understanding Public and 
Private Property Settings (page 37). 

10 Click  Save and then continue with the next section Setting Up PCS Axis 
(page 36) to continue setting up PCS Axis for operation. 
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Figure 3-4.  Hierarchy Levels

Related Topics

• Understanding Public and Private Property Settings

Setting Up PCS Axis
PCS Axis provides several property settings that allow you to customize the software 
according to your company’s business needs. Other settings effect the functionality of 
certain PCS Axis features. Information in this section explains how to set each of these 
property settings. Topics include those in the following list: 

• Understanding Public and Private Property Settings

• Setting Options (page 38)

• Working with Custom Security Roles (page 57)

• Setting Properties in Field and UDF Customizations (page 68)
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• Using an Application Scheme (page 120)

• Choosing a Printer for PCS Axis (page 120)

Understanding Public and Private Property Settings
Some property settings in Options, once configured, apply to all users, while others can be 
changed by an individual user for their login. Property settings that include a Public 
caption can only be changed by a SysAdmin, and the setting made by the SysAdmin 
applies globally to all users. For property settings accompanied by a Private check box, 
the SysAdmin can determine whether or not a general user can modify the property 
setting. See Figure 3-5.

When the Private check box is checked, the currently logged in user can change the 
associated property setting. Changes are “private” and only apply to the logged in user 
who makes a change to the setting. If a Private check box is unchecked, the associated 
property setting made by the SysAdmin applies globally to all users and only the 
SysAdmin can change this value. 

Figure 3-5.  Options Public and Private Property Settings 

Only a SysAdmin can see Private check boxes. For all other users, a Private caption 
appears alongside the “private” and editable property settings. A Public caption is 
displayed for globally-applied settings.
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Setting Options
PCS Axis uses property settings in Options to perform many functions across all modules, 
such as arranging data, performing calculations, generating reports, and allowing user-
access to certain features. Required settings include Hierarchy levels, Company Name, 
User Location Name, and Criteria. If optional add-ons have been purchased, such as 
Bridge or Bridge with Bullhorn integration, setting properties for these features are also 
required. 

Information in this section explains how to set properties in Options. Topics in this section 
include those in the following list:

• Setting Bullhorn Options (SysAdmins Only) (page 39)

• Setting Criteria Options (page 40)

• Setting Editing Options (page 41)

• Setting Email Notification Options (page 44)

• Setting Field Computer Options (page 47)

• Setting General Options (page 48)

• Setting Hierarchy Options (page 51)

• Setting Report Options (page 51)

• Setting Security Options (page 52)

• Setting Synchronization Options (SysAdmins Only) (page 54)

• Disabling Synchronization (SysAdmins Only) (page 57)

NOTE: A Public caption indicates the associated property setting applies globally to all 
users and can only be changed by a SysAdmin.  
 
(SysAdmin only) For options accompanied by a Private check box, check or uncheck the 
check box based on your company’s requirements. When the Private check box is 
checked, the currently logged in user can change the associated property setting. For 
more information, see Understanding Public and Private Property Settings (page 37). 

Related Topics

• Understanding Public and Private Property Settings
38 Setting Up PCS Axis



PCS Axis User and Administrator Guide
Setting Bullhorn Options (SysAdmins Only)
If you plan to use Bridge to transfer data from your account on Bullhorn Asset Tracker 
(BAT™), ensure the Bullhorn options are set first. A Public caption in this Options screen 
indicates the associated property setting applies globally to all users and can only be 
changed by a SysAdmin. 

Complete the following steps to set Bullhorn property settings in Options:

1 Click Tools > Options > Bullhorn tab to open the Bullhorn options page 
(Figure 3-6). 

NOTE: You can also display the Bullhorn options page by clicking the  arrow 
above the navigation panel and then selecting Bullhorn in the selection list that 
opens. 

2 Type http://www.bullhornsys.com/BATAPI/BATAPI.svc/extract in the field 
Extract Endpoint Url. 

3 Type http://www.bullhornsys.com/BATAPI/BATAPI.svc/mapping in the field 
Mapping Endpoint Url. 

4 Click  Save to save changes. 

Figure 3-6.  Bullhorn Options

Related Topics

• Understanding Public and Private Property Settings
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Setting Criteria Options
The Criteria options screen sets the following property settings: (if available) Telluric 
threshold, days between an inspection reading and pipe-to-soil reading, and casing 
criteria. A Public caption in this Options screen indicates the associated property setting 
applies globally to all users and can only be changed by a SysAdmin. 

Complete the following steps to set the Criteria options:

1 If the Options window is not open, click Tools > Options to open the window. 
Then click the Criteria tab to open the Criteria options page (Figure 3-7 
(page 41)). 

2 If your PCS Axis license includes the optional Telluric Compensation feature, the 
field labeled Default Telluric Threshold is present in the Criteria page. 

The default threshold used to identify telluric effects in an SDL (stationary data 
logger) data set is 0.010 volts. If you want to change the default threshold, type a 
value in volts in the field Default Telluric Threshold.

PCS Axis calculates a baseline average for survey measurements in an SDL data set. 
If any survey measurement in the data set is above or below the baseline average 
by 0.010 volts, this indicates the data set exhibits telluric current effects. 

NOTE: For information about how to upgrade a PCS Axis license to include 
Telluric Compensation, contact Technical Support (page 25). 

3 Identify the isolation criteria for casing inspections. Type a value in the field Casing 
Criteria Minimum Difference Between P/S and C/S to set the minimum 
difference allowed between pipe-to-soil (P/S) and casing pipe-to-soil (C/S) 
readings before the casing is considered shorted. The default setting is 100 mV. 

NOTE: PCS Axis displays a warning message when the minimum difference does 
not meet the casing criteria for an inspection reading entered in the data entry 
grid. Similarly, an entry is added in the Field Computer Log when inspection 
readings transferred from the Allegro do not meet casing criteria. 
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4 Identify the number of days after an inspection reading is taken that a native pipe-
to-soil (P/S) reading is taken. Type the number of days in the field Days To Look 
Forward From Inspection For Native P/S. 

NOTE: The number of days effects the system calculation for the fields Effective 
Native P/S and Effective Native Date in data entry grids. Native P/S is a potential 
reading taken prior to any current placed on the pipeline. It is also referred to as a 
depolarized or static potential reading. 

5 (SysAdmin only) For property settings accompanied by a Private check box, check 
or uncheck the check box based on your company’s requirements. When the 
Private check box is checked, the currently logged in user can change the 
associated property setting. For more information, see Understanding Public and 
Private Property Settings (page 37). 

6 Click  Save to save changes. 

Figure 3-7.  Criteria Options

Related Topics

• Understanding Public and Private Property Settings

Setting Editing Options
Making changes to the Editing properties alters the behavior when entering data in data 
entry grids. A Public caption in this Options screen indicates the associated property 
setting applies globally to all users and can only be changed by a SysAdmin. 
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 Complete the following steps in the Editing page of Options: 

1 If the Options window is not open, click Tools > Options to open the 
window. 

2 Click the Editing tab to open the Editing options page (Figure 3-8). 

Figure 3-8.  Editing Options

3 Review the information in Table 3-1 and check or uncheck an option’s check box or 
select from the drop downs as needed. 

4 (SysAdmin only) For property settings accompanied by a Private check box, check 
or uncheck the check box based on your company’s requirements. When the 
Private check box is checked, the currently logged in user can change the 
associated property setting. For more information, see Understanding Public and 
Private Property Settings (page 37). 

5 When you finish, click  Save to save changes. 
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Table 3-1.  Editing Options 

Option Description

Date Carry Forward 
Enabled Option

Use the last entered survey date as the survey date for the 
next record when working in an Inspection grid or form.

Technician Carry 
Forward Enabled 
Option

Technician Carry 
Forward Method 
Option

When entering inspection/maintenance data in either the 
Inspection or Maintenance grid, automatically enter a 
person’s name in the Technician field (Inspection grid) or 
Repair Technician (Maintenance grid) using one of the 
following methods: 

• Last Technician: Use the name of the last person 
entered in the Technician field. 

• Security: Use the name of the person currently 
logged into PCS Axis. 

Timestamp Readings 
Enabled Option

Add today’s date as the inspection date when entering 
readings in the Inspection grid. 

Show Detail Inspection 
Entry Grid

Display the CPDM Test Point Inspection Detail mini-
grid. Enabling this option allows you to work with test 
points that have multiple potential readings, such as a 
test point with multiple readings for Structure P/S, 
Casing P/S, or On/Off Pair user defined fields (UDFs). 

NOTE: This system option is not present when using the 
optional PCS Axis Telluric Compensation feature. The 
mini-grid displays by default and cannot be disabled. 

Show Grid Tooltips 
Option

Display a field description when the user hovers the 
mouse over a data entry field. 

Warn When Below 
Protection Criteria 
Enabled Option

Display a warning message when a user enters an 
inspection reading that is below the protection criteria 
value specified in the Test Point Protection Criteria field 
of the facility Information grid. 

Require Remarks When 
Range Or Criteria Is 
Violated Option

Display a message prompting the user to edit the 
inspection reading or enter a description in the 
Inspection Remarks field when the entered reading is 
out of range or does not meet the criteria limit specified 
in Options (Tools > Options > Criteria). 

Warn Before Permanent 
History Record 
Changed Option

Display a warning message to the user before changes 
are made to a permanent history record. AI recommends 
this option be enabled if your company plans to maintain 
history records. 

Warn When Outside 
Established Range 
Values Enabled Option

Display a warning message when a user enters an 
inspection reading that is out of range or under criteria. 
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Related Topics

• Understanding Public and Private Property Settings

Setting Email Notification Options
The Email Notification options determine how email reports should be sent. A Public 
caption in this Options screen indicates the associated property setting applies globally to 
all users and can only be changed by a SysAdmin. 

Complete the following steps to set Email Notification property settings: 

1 If the Options window is not open, click Tools > Options to open the 
window. Then click the Email Notification tab (Figure 3-9). 

Figure 3-9.  Email Notification Options 

2 Type the host name of the SMTP email server your company uses to send email in 
the field Email Smtp Host Name. 

NOTE: SMTP is an acronym for Simple Mail Transfer Protocol. It is a data 
transmission format used to send email. 

3 Type a user name in the field Email Smtp User Name that is associated with the 
email address you plan to use for sending email notifications. 

4 Type a password in the field Email Smtp Password that is associated with the 
user name and email address you plan to use for sending email notifications. 
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5 In the field Email From, type the email address you plan to use for sending email 
notifications. 

6 If the email server supports SSL protocol, click the check box Email Enable Ssl to 
place a check mark inside the check box. 

When an email server supports SSL (secure socket layer) protocol, the email server 
transmits information in an encrypted form for security purposes. If needed, 
contact your IT System Administrator to determine if your company’s email server 
supports SSL.

NOTE: When Email Enable Ssl is disabled (empty check box) and the email server 
supports SSL protocol, recipients will not receive PCS Axis email notifications. PCS 
Axis also adds an entry in the log of Job Service Viewer to identify email 
notification failures (Tool > Job Service Viewer > Job History > Log). 

7 Use the check box Disable Email Service to stop or start sending email 
notifications to all email recipients. 

To stop sending email notifications to all recipients, click the check box to place a 
check mark inside the check box. To begin sending email notifications again, clear 
the check mark by clicking the check box. For more information, refer to Stopping 
Delivery of Email Notifications (page 589). 

8 Enter a default time to send email notifications in the field Email Default Time. 
Use 12-hour time format to indicate the hour, minute, and AM/PM setting (HH:MM 
AM/PM). The default time is used when an email report is not set up with a delivery 
time in the Email Reports tab of Email Notification (Tools > Email Notification > 
Email Reports tab). 

IMPORTANT: When setting a default time to send email notifications, choose a 
time that does not impact other network services or computer resources. 

9 In the field Email Log Retention In Days, enter the number of days to store a 
copy of the email log in the database. Entries in the email log are purged from the 
log after the specified number of days. 

IMPORTANT: Storing the email log in the database increases the size of the 
database. PCS Axis adds an entry in the log each time an email is sent. The log also 
includes email recipient information; email delivery mode and frequency; hierarchy 
assignments; and email report attachments in Adobe® PDF format. 
Setting Up PCS Axis 45



PCS Axis User and Administrator Guide
10 In the field Email Max Attachment Size In Mb, enter a value in megabytes (MB) 
that identifies the maximum size allowed by the email server for attachments in an 
email. Because some email servers are set up to process emails no larger than 10 
MB in size, it may be necessary to contact your IT department for this information 
to ensure email recipients receive email notifications. 

11 Click  Save to save changes. 

Related Topics

• Understanding Public and Private Property Settings
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Setting Field Computer Options
The Field Computer options provides access to property settings related to the Allegro 
Field PC. A Public caption in this Options screen indicates the associated property setting 
applies globally to all users and can only be changed by a SysAdmin. 

If your company plans to use the Allegro Field PC with PCS Axis, complete the following 
steps to set up Field Computer options:

1 If the Options window is not open, click Tools > Options to open the 
window. Then click the Field Computer tab (Figure 3-10). 

2 To only use the Allegro digital voltmeter to record voltage readings, enable the 
option Require Voltage Readings By Voltmeter. Enabling this option prevents 
manual data entry of voltage readings on the Allegro. 

3 (SysAdmin only) For property settings accompanied by a Private check box, check 
or uncheck the check box based on your company’s requirements. When the 
Private check box is checked, the currently logged in user can change the 
associated property setting. For more information, see Understanding Public and 
Private Property Settings (page 37). 

4 Click  Save to save changes. 

Figure 3-10.  Field Computer Options

Related Topics

• Understanding Public and Private Property Settings
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Setting General Options
The General options set general PCS Axis property settings, such as display settings and 
general behaviors. A Public caption in this Options screen indicates the associated 
property setting applies globally to all users and can only be changed by a SysAdmin. 

To set property settings in the General page of Options, follow these steps: 

1 If the Options window is not open, click Tools > Options to open the 
window. 

2 Click the General tab to open the General options page (Figure 3-11). 

Figure 3-11.  General Options

3 Review the information in Table 3-2 (page  49) and check the options’ check boxes 
or select from the drop downs as needed.

4 (SysAdmin only) For property settings accompanied by a Private check box, check 
or uncheck the check box based on your company’s requirements. When the 
Private check box is checked, the currently logged in user can change the 
associated property setting. For more information, see Understanding Public and 
Private Property Settings (page 37). 

5 When you finish, click  Save to save changes. 
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Table 3-2.  General Options 

Option Description

Disable Attached 
Document Preview

Applies to documents that have previously been 
attached to a record in a data grid. When the option is 
enabled, users are unable to preview an attached 
document in the Preview Attached Documents 
window. When the option is disabled, users can open an 
attached document for editing or viewing purposes if 
the file type of the attached document is associated with 
a default software program on their local computer. See 
Viewing an Attached Document (page 165) for related 
information. 

Include Unit Of Measure 
In All Captions

Include the unit of measure in the description of column 
headings and field captions, such as Structure P/S 
(Volts).

Company Name Provide your company's name. It appears at the top level 
of the PCS Axis system hierarchy and in the header of all 
reports.

Metric Milepost Delimiter Choose Period, Comma, or Plus in the selection list to 
identify the delimiter used in the formatting of metric 
mileposts, such as 1.234AB (Period), 1,234AB (Comma), 
or 1+234AB (Plus). Values before the metric delimiter 
indicate kilometers. Values after the metric delimiter 
indicate meters. For example, milepost number 1.234AB 
indicates 1 kilometer (km) and 234 meters (m). 
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Survey Status Behavior Selections for Survey Status Behavior effect the 
inspection field labeled Surveyed, which is a PCS Axis 
calculated field. 

The Survey Status Behavior option you select identifies 
which conditions must be met in order for PCS Axis to 
determine the facility survey status. When conditions are 
met, PCS Axis places a check mark in the Surveyed check 
box to indicate the facility has been inspected and a 
survey reading has been recorded.   

Review the following information and then choose an 
option in the Survey Status Behavior selection list:   

Any: The Inspection grid must include at least one 
inspection field with a survey reading before PCS Axis 
considers the facility has been surveyed. 

All: All fields related to the inspection field must be 
populated before PCS Axis considers the facility has 
been surveyed. Related fields include the Activate field 
for the inspection field in the Information grid; a survey 
reading in the inspection field of the Inspection grid; 
and Yes in the property setting for the field labeled 
System-Inspection Surveyed in Field and UDF 
Customizations. 

Use Date Only Only display the date instead of date and time for date 
fields such as Inspection Date in the Inspection grid 
and Repair Found Date in the Maintenance grid. 

User Location Name Identify the name your company uses to refer to 
inspection points on a pipeline. For example, type 
Milepost, Station Number, or other type of descriptor 
in the field User Location Name. 

Table 3-2.  General Options (continued)

Option Description
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Related Topics

• Understanding Public and Private Property Settings

Setting Hierarchy Options
Hierarchy options determine how PCS Axis organizes data in the system. For information 
about how to set up the PCS Axis system hierarchy, refer to the previous sections 
Understanding the System Hierarchy (page 33) and Setting the System Hierarchy 
(page 34). 

Related Topics

• Understanding Public and Private Property Settings

Setting Report Options
The Reports options determine which signature line caption is used. A Public caption in 
this Options screen indicates the associated property setting applies globally to all users 
and can only be changed by a SysAdmin. 

Complete the following steps in the Reports page of Options to set property settings: 

Disable Link Attachments Disable Link Attachments is a system option that 
applies when attaching a document to a record in a data 
grid (Tools > Options > General). When the option is 
enabled, a document can be embedded but not linked 
to a record. A copy of an embedded document stores in 
the PCS Axis database and can be accessed by all PCS 
Axis users. A linked document stores on the local 
computer of the user who linked the document and can 
only be accessed by that user. 

If your company prefers that users embed documents 
instead of linking to documents, enable the option by 
clicking the check box. A check mark inside the check 
box indicates the option is enabled. For more 
information, refer to Attaching a Document to a Grid 
Record (page 340). 

Table 3-2.  General Options (continued)

Option Description
Setting Up PCS Axis 51



PCS Axis User and Administrator Guide
1 If the Options window is not open, click Tools > Options to open the 
window. 

2 Click the Reports tab to open the Reports option page (Figure 3-12, page 52). 

3 If you want to change the default setting used as the caption below the signature 
line in a Columnar report (Surveyor), type a name in the field Signature Line 
Caption. 

4 (SysAdmin only) For property settings accompanied by a Private check box, check 
or uncheck the check box based on your company’s requirements. When the 
Private check box is checked, the currently logged in user can change the 
associated property setting. For more information, see Understanding Public and 
Private Property Settings (page 37). 

5 Click  Save to save changes. 

Figure 3-12.  Reports

Related Topics

• Understanding Public and Private Property Settings

Setting Security Options
Security-related property settings can be configured in the Security page of Options. A 
Public caption in this Options screen indicates the associated property setting applies 
globally to all users and can only be changed by a SysAdmin. 

 Complete the following steps in the Security page of Options to set property settings: 
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1 If the Options window is not open, click Tools > Options to open the 
window. 

2 Click the Security tab to open the Security options page (Figure 3-13). 

Figure 3-13.  Security Options

3 Review the information in Table 3-3 (page  53) and check or uncheck an option’s 
check box or select from the drop downs as needed. 

4 (SysAdmin only) For property settings accompanied by a Private check box, check 
or uncheck the check box based on your company’s requirements. When the 
Private check box is checked, the currently logged in user can change the 
associated property setting. For more information, see Understanding Public and 
Private Property Settings (page 37). 

5 When you finish, click  Save to save changes. 

Table 3-3.  Security Options 

Option Description

Use Hierarchical Security Enable this option if you plan to set up hierarchy rights 
in User Management for users with User and Read 
Only security permissions. 

Hierarchical security allows you to assign users access 
rights to certain hierarchy folders in the Select ROWs 
window. When a user does not have access rights to a 
hierarchy folder, PCS Axis does not display the folder in 
the Select ROWs window.
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Related Topics

• Understanding Public and Private Property Settings

Setting Synchronization Options (SysAdmins Only)
The following procedure explains how to set property settings for Synchronization in 
system Options. If you want to disable Synchronization, see Disabling Synchronization 
(SysAdmins Only) (page 57). A Public caption in this Options screen indicates the 
associated property setting applies globally to all users and can only be changed by a 
SysAdmin. 

Requires Windows 
Password

If you want users to enter their Windows password when 
logging in to PCS Axis, click the option Requires 
Windows Password. When this option is disabled, the 
system automatically logs in users with their Windows 
login credentials (user name and password 
combination).

Table 3-3.  Security Options (continued)

Option Description
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Complete the following steps: 

1 Click Tools > Options > Synchronization to open the synchronization 
property settings window (Figure 3-14). 

Figure 3-14.  Synchronization

2 Review the following information and then set options as needed. When you finish, 
click  Save to save changes. 

• Default Subscription Database Name: This property setting identifies the 
default name applied to all subscription databases when setting up 
subscribers in Configure Subscription (Tools > Configure Subscription). If 
you want to use a different default name, type a name in this field. 

NOTE: You also have the option to use a different name than the default when 
setting up each subscription database. See Configuring a Subscription 
(page 783) for more information if needed. 
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• Subscription Expiration Warning Threshold: This property setting 
applies to all subscription databases that have not synchronized with the 
publication database within the publication retention period. 

The warning threshold is the number of days before a subscription expires that 
a warning message displays indicating the subscriber must synchronize their 
subscription database. The default value is 10 days. To change the default 
setting, type a value in this field. 

IMPORTANT: Publication retention period is also referred to as subscription 
expiration period. A subscription becomes expired (obsolete) when the 
subscriber does not synchronize their subscription database with the 
publication database within the publication retention period. An expired 
subscription must be re-initialized at the publisher (network server with 
publication database).  
 
The publication retention period is set in the field Subscription expiration in 
the General page when using SQL Server Management Studio (SSMS). See 
Confirming Share Folder Access (page 778) for more information.

• Synchronization User Group Name: This property setting identifies your 
company’s domain name and the name of the local domain user group set up 
for PCS Axis on the central database server. If needed, contact your company’s 
IT System Administrator for this information. When entering the 
Synchronization User Group Name, format the information as shown in the 
following example: 

Example: Domain Name\User Group Name 

• Disabling Synchronization: See the section titled Disabling Synchronization. 

Related Topics

• Disabling Synchronization (SysAdmins Only)
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Disabling Synchronization (SysAdmins Only)
If your company does not plan to use Synchronization, you have the option to disable the 
feature. When disabled, the Synchronization menu command is not included in the Tools 
menu, which prevents creating the publication and subscription databases. You can 
however activate Synchronization at anytime if your company decides later to use the 
feature. 

To disable Synchronization, follow these steps:

1 Click Tools > Options > Synchronization to open the synchronization property 
settings window (Figure 3-15). 

2 Click the check box Disable Synchronization to place a check mark inside the 
check box. Then click  Save. 

The Synchronization menu command is no longer available in the Tools menu. If 
you decide later to activate Synchronization, clear the check mark by clicking the 
Disable Synchronization check box. 

Figure 3-15.  Disable Synchronization

Working with Custom Security Roles
Custom security roles are an optional feature in PCS Axis that is setup by the PCS 
administrator. The security feature allows you to grant or deny user access to PCS Axis 
menus and menu commands as well as data entry fields. 
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A custom security role is a named set of permissions based on your company’s business 
requirements. You create a custom security role using a Parent Role as a template and 
then modify permissions in the custom security role as needed. Roles include permissions 
for menu-level items (File, Modules, Data Entry, Report/Graphs, Tools, and Field 
Computer) as well as field-level items (Facility Surveys, Continuous Surveys, and ROW 
and Pipeline).

A Parent Role is a PCS Axis installed security role with predefined permissions that cannot 
be modified. Parent roles include the SysAdmin, User, and Read Only security roles. After 
creating a custom security role based on a parent role, you can then assign it to a PCS Axis 
user who was set up in User Management. 

Information in this section explains how to use Security Role Management to add and 
edit a custom security role. Topics include those in the following list: 

• Adding a Custom Security Role (page 59)

• Using Copy to Add a Custom Security Role (page 60)

• Editing a Custom Security Role (page 61)

• Deleting a Custom Security Role (page 65)

• Assigning a Custom Security Role to a User (page 66)
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Adding a Custom Security Role
Complete the following steps to add a custom security role:

1 Click Tools > Security Role Management to open the Security Role 
Management window (Figure 3-16). 

Figure 3-16.  Security Role Management

NOTE: The  icon denotes fields that are unavailable for this role.

2 Click  Add to open the Add Security Role dialog box (Figure 3-17). 

Figure 3-17.  Add Security Role

3 Select a Parent Role to use as a template to create the custom security role. Click 
the down arrow in the Parent Role field and select a PCS Axis installed security 
role in the selection list, such as User or SysAdmin. 

4 Type a name for the custom security role in the Name field and a description in 
the Description field. Fields marked with a  icon are required.
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5 Click  OK to save changes and return to Security Role Management. 
Information about the custom security role display in the fields Parent Role, Role, 
and Description. 

6 Repeat step 2 through step 5 as needed to add additional custom security roles. 
Then continue with the next section to edit permissions in a custom security role. 

Related Topics

• Working with Custom Security Roles

• Using Copy to Add a Custom Security Role

• Editing a Custom Security Role

• Deleting a Custom Security Role

• Assigning a Custom Security Role to a User

Using Copy to Add a Custom Security Role
When you want to add a custom security role with permissions that are slightly different 
than those in an existing customer security role, use the Copy command to copy 
permissions from the existing custom security role. 

To add a custom security role using the Copy command, follow these steps: 

1 If the Security Role Management window is not open, click Tools > Security 
Role Management (Figure 3-16, page 59). 

2 Click  Copy to open the Copy Security Role dialog box (Figure 3-18). 

Figure 3-18.  Copy Security Role

3 Click the down arrow in the Parent Role field and select the parent role associated 
with the existing custom security role. 
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4 Click the down arrow in the Role field and select the existing custom security role 
with permissions you want to copy to the new custom security role. 

5 Type a name for the new custom security role in the Name field. Fields marked 
with a  icon are required. 

6 Enter a description for the custom role, if desired, in the Description field.

7 Click  OK to save changes and return to the Security Role Management 
window. 

8 Repeat step 2 through step 7 as needed to add additional custom security roles. 
Then continue with the next section to edit permissions in a custom security role. 

Editing a Custom Security Role
To edit permissions in a custom security role, follow these steps:

1 If the Security Role Management window is not open, click Tools > Security 
Role Management. 

2 Click the down arrow in the Role field and select a custom security role in the 
selection list. Then click  Edit to begin editing permissions (Figure 3-19). 

NOTE: If the custom security role is not visible in the selection list, click the down 
arrow in the Parent Role field and select either User or SysAdmin, then select the 
custom security role in the Role field. 

Figure 3-19.  Edit Security Role - Menu Edit Tab

3 Click the Menu Edit tab (step 4) or the Fields Edit tab (step 7) to edit permissions.

4 Use the following methods to edit menu permissions for the custom security role:
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NOTE: You can toggle permissions on and off for all items in the window. Click 
 All to grant access to all items or  None to deny access to all items. 

NOTE: Use the Search box located above the Display Name column to quickly 
find a command name.

a To grant access to an entire menu listed in the Display Name column, click the 
adjacent check box to place a check mark inside the check box . 

b To deny access to an entire menu listed in the Display Name column, click the 
adjacent check box to remove the check mark inside the check box . 

c To grant or deny access to sub-menu commands, click the arrow next to the 
main menu name to expand the list (Figure 3-20).

Figure 3-20.  Expanded Menu Commands

NOTE: The columns can be expanded by hovering over the dividing line until 
the cursor changes to  and then clicking and dragging the cursor. 

d To grant access to a sub-menu listed in the Display Name column, click the 
adjacent check box to place a check mark inside the check box . 

e To deny access to a sub-menu listed in the Display Name column, click the 
adjacent check box to remove the check mark inside the check box . 
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f Repeat step 4 as needed for each menu and sub-menu command listed in the 
Display Name column. 

5 Click  Save to save changes. 

6 Click the Fields Edit tab to edit permissions for fields (Figure 3-21).

Figure 3-21.  Edit Security Role - Fields Edit Tab

7 Use the following methods to edit field permissions for the custom security role:

NOTE: You can toggle permissions on and off for all items in the window. Click 
 All to grant access to all items or  None to deny access to all items. 

NOTE: Use the Search box located above the Display Name column to quickly 
find a field name.

a To grant access to an entire category listed in the Display Name column, click 
the adjacent check box to place a check mark inside the check box . 

b To deny access to an entire category listed in the Display Name column, click 
the adjacent check box to remove the check mark inside the check box . 

c To grant or deny access to sub-category fields, click the arrow next to the main 
category name to expand the list (Figure 3-22).
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Figure 3-22.  Expanded Fields

NOTE: The columns can be expanded by hovering over the dividing line until 
the cursor changes to  and then clicking and dragging the cursor. 

d To grant access to a sub-category field listed in the Display Name column, 
click the adjacent check box to place a check mark inside the check box . 

e To deny access to a sub-category field listed in the Display Name column, 
click the adjacent check box to remove the check mark inside the check box 

. 

f Repeat step 7 as needed for each category and sub-category field listed in 
the Display Name column. 

8 Click  Save to save changes. 

To assign a custom security role to a user previously set up in User Management, 
see Assigning a Custom Security Role to a User (page 66).

Related Topics

• Working with Custom Security Roles

• Using Copy to Add a Custom Security Role

• Editing a Custom Security Role
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• Deleting a Custom Security Role

• Assigning a Custom Security Role to a User

Deleting a Custom Security Role
To delete a custom security role, follow these steps:

1 If the Security Role Management window is not open, click Tools > Security 
Role Management (Figure 3-16, page 59). 

2 Click the down arrow in the Parent Role field and select the parent role associated 
with the custom security role you want to delete. 

3 Click the down arrow in the Role field and select the custom security role you want 
to delete. 

4 Click  Delete. When the Confirm Delete message displays, click  Yes to 
delete the custom security role and set users tied to this role to the PCS Axis 
installed role or  No to cancel the operation (Figure 3-23). 

Figure 3-23.  Confirm Delete

Related Topics

• Working with Custom Security Roles

• Adding a Custom Security Role

• Using Copy to Add a Custom Security Role

• Editing a Custom Security Role

• Assigning a Custom Security Role to a User
Setting Up PCS Axis 65



PCS Axis User and Administrator Guide
Assigning a Custom Security Role to a User
The following information explains how to assign a custom security role to a user set up in 
User Management. For more information about User Management, see Setting Up User 
Management (page 187). 

Complete the following steps:

1 Click Tools > User Management to open the User Management window 
(Figure 3-24). 

Figure 3-24.  User Management

NOTE: If the Hierarchy Rights panel is open, click the title bar to collapse it.

2 Select a user record in the grid. 
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3 Complete the following steps in the Role group box on the left side of the window 
(Figure 3-25):

Figure 3-25.  Role List

a Click the Parent Role field and select the parent role associated with the 
custom security role you want to assign to the user record. 

b Click the Role field and select the custom security role you want to assign to 
the user record. 

4 Click  Save to save changes

Related Topics

• Working with Custom Security Roles

• Adding a Custom Security Role

• Using Copy to Add a Custom Security Role

• Editing a Custom Security Role

• Deleting a Custom Security Role
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Setting Properties in Field and UDF Customizations
Use Field and UDF Customizations to modify property settings for certain PCS Axis 
installed fields and add one or more user-defined fields (UDFs) when PCS Axis does not 
provide a field for data entry. 

Information in this section explains how to use the most common features of Field and 
UDF Customizations. Topics include those in the following list: 

• Navigating Field and UDF Customizations

• Editing a PCS Axis Installed Layout Theme (page 69)

• Adding a Layout Theme Addition (page 72)

• Renaming Field Captions on page 74

• Setting Up Range Checking for Inspection Fields on page 77

• Adding User Defined Fields on page 79

Navigating Field and UDF Customizations
The selection tree in the Properties panel of Field and UDF Customizations includes 
three main categories labeled Facility Surveys, Continuous Surveys, and ROW and 
Pipeline. Each of these categories includes related items for selection. For example, items 
for selection in Facility Surveys are based on module and data grid. Items for selection in 
Continuous Surveys are based on data grid and the various continuous survey types. 

Selecting an item in the selection tree displays a list of related fields and property settings 
in the adjacent grid. The grid layout includes columns, rows and cells similar to a 
spreadsheet. Grid columns at top of the grid identify the names of the various properties 
you can set up for a field. Each grid row contains property settings for a specific field, such 
as Casing Status shown in the following figure (Figure 3-26, page 69). When a property 
setting is shaded gray or includes the label N/A (not applicable), this indicates the setting 
cannot be modified. 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to view 
more of the grid. Clicking the bar again expands the panel. 
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Figure 3-26.  Field and UDF Customizations

Editing a PCS Axis Installed Layout Theme
A layout theme is a named set of fields that are present in the grid when working in Field 
and UDF Customizations. Two types of layout themes are available for use. They include 
installed and addition layout themes. An installed layout theme is one that has been 
installed during the PCS Axis software installation, such as [PCS] All Fields. A layout theme 
addition is one that you create.

The procedure in this section explains how to complete the following tasks to edit a PCS 
Axis installed layout theme: 

• add and remove fields in an installed layout theme

• revert an installed layout theme

• save changes as a new baseline installed layout theme

2

1
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List of fields.2

Grid column labeled 
with the name of the 
property setting.

4

3

Grid row with field 
property settings.
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To edit a PCS Axis installed layout theme, follow these steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-27). 

Figure 3-27.  Field and UDF Customizations

2 Click  Customize to open the Column Selections dialog box (Figure 3-28). 

3 Click the down arrow in Select Layout Theme and select a theme in the selection 
list, such as  [PCS] All Fields. 

NOTE: By default all fields are included in the  [PCS] All Fields layout theme. If 
you want to clear all fields listed in the right pane and subsequently remove them 
from the layout theme, click  Toggle Select. Clicking the button again moves all 
fields to the right pane and adds them in the layout theme. 

4 To remove one or more fields in the layout theme, complete one of the following 
steps (Figure 3-28, page 71): 

a Select a field in the right pane and then click the bottom arrow button  to 
move the field to the left pane. 

b Double-click a field in the right pane to move it to the left pane. 
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NOTE: The grid layout theme includes all fields listed in the right pane of the 
Column Selections dialog box. 

Figure 3-28.  Column Selections

5 Click  Save to save changes. 

6 To revert an installed theme and restore settings prior to editing:

• Click  Revert, then click Yes when the Confirm Revert message displays. 

7 To save current changes as new baseline settings, click  New Baseline. 
When future changes are made and then reverted, PCS Axis restores the 
theme with baseline settings.
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Adding a Layout Theme Addition
Information in this section describes how to add a new grid layout theme in Field and 
Customizations. Adding a layout theme allows you to choose which fields to include in 
the grid and then save the new layout as a theme for later use. 

To add a grid layout theme, follow these steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29). 

Figure 3-29.  Field and UDF Customizations

2 Click  Customize to open the Column Selections dialog box (Figure 3-30). 

Figure 3-30.  Column Selections
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3 Click  Add to open the New Layout Theme dialog box (Figure 3-31). 

Figure 3-31.  New Layout Theme

4 Type a name for the layout theme in the field Enter Theme Name. If you want to 
create a public theme, click the Public check box to place a check mark inside the 
check box. When the check box is empty, the layout saves as a private theme. 

NOTE: Themes are either public or private. A public theme is available for use by 
all PCS Axis users. A private theme is available only to the user who creates it. Also, 
only public themes will be available for selection for layouts, sorts, or reports.

5 Select a layout theme with fields you want to copy to the new layout theme. Click 
the down arrow in Copy Fields From Theme and select a theme in the selection 
list. 

6 Click  Save to save changes and return to the Column Selections dialog box. 

7 If you want to clear all fields listed in the right pane of the dialog box and 
subsequently remove them from the grid, click  Toggle Select. Clicking the 
button again moves all fields to the right pane and adds them in the grid. 

8 Choose which fields to include in the layout theme. Select a field in the left pane 
and then click the top arrow button  to move the field to the right pane. Repeat 
this step as needed (Figure 3-32, page 74). 

9 If you want to remove a field in the layout theme, select a field in the right pane 
and then click the bottom arrow button  to move the field to the left pane. 
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NOTE: The grid layout theme includes all fields listed in the right pane of the 
Column Selections dialog box. 

10 Click  Save to save changes and return to the Field and UDF Customizations 
grid. 

Figure 3-32.  Column Selections

Renaming Field Captions
You can rename many of the original PCS Axis field captions with a caption that is more 
familiar to users in your company. The following procedure explains how to rename field 
captions. The information is intended for users with SysAdmin user permissions. 

Complete the following steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 
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3 Select an item in the Properties panel to display related fields and property 
settings in the grid. 

For example, double-click Facility Surveys > Common to All Facilities > ROW 
and Pipeline. The grid displays related fields and property settings for ROW and 
Pipeline (Figure 3-33). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-33.  Field and UDF Customizations

4 To rename an original field caption listed in the Original Caption grid column:

• Type a name in the adjacent field listed in the Caption grid column. 

For example, to rename Milepost, type a new description in the adjacent field, 
such as Station. Bold text indicates a user-modified field as shown in Figure 3-
34, page 76. 
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Figure 3-34.  Field and UDF Customizations

Returning a Field Caption to its Original Name
To return a field caption to its original name, follow these steps:

1 If the Field and UDF Customizations window is not open, click Tools > Field and 
UDF Customizations (Figure 3-29, page 72). 

2 Select an item in the Properties panel with the field caption you want to return to 
its original name. 

3 Highlight the name in the Caption field and then press the Delete key on the 
computer keyboard. 

NOTE: If the cursor is still in the Caption field after typing a a new name, you can 
also press Ctrl+Z to undo changes and display the original field caption. 
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Setting Up Range Checking for Inspection Fields
Range checking is the acceptable range of values allowed for data entry in an inspection 
field. 

Setting up range checking allows PCS Axis to alert the user when an incorrect value has 
been entered in an inspection field. For example, if the acceptable range of values is in a 
range of -10 to 0 and the user enters a value that is outside this range, a warning message 
displays allowing the user to correct the invalid entry. Data entry errors are less likely to 
occur when inspection fields are set up with range checking. 

Settings apply system-wide when range checking is set up for an inspection field in Field 
and UDF Customizations. You can also set up range checking at the facility level using 
the minimum/maximum fields available in the Information and Inspections data entry 
grid. Range checking at the facility level overrides range checking at the system level. 

Complete the following steps to set up range checking for an inspection field: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the inspection field you want 
to set up for range checking. 

For example, double-click Facility Surveys > CPDM > Test Point > Test Point 
Inspection. The grid displays related fields and property settings for the Test 
Point Inspection data entry grid (Figure 3-35, page 78). 

4 Select the inspection field you want to set up for range checking. For example, 
select Casing P/S as shown in the following figure (Figure 3-35, page 78). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 
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Figure 3-35.  Field and UDF Customizations

5 Locate the grid columns labeled System–Default Minimum Range and 
System–Default Maximum Range. 

6 Type a minimum range value in the field labeled System–Default Minimum 
Range for the selected inspection field. 

7 Type a maximum range in the field labeled System–Default Maximum Range 
field for the selected inspection field. 

8 If you want to set up another inspection field with range checking, repeat step 
3 through step 7. When you finish, click the  close icon to close the Field and 
UDF Customizations window. 
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Adding User Defined Fields
A user defined field (UDF) is a field you create when PCS Axis does not provide a field for 
data entry. The types of UDFs available for use include those in the following list: 

• Normal: Set up a normal UDF when you want to add any of the following types of 
fields: character, numeric, date, logical, memo, or date/time field.

• Calculated: Set up a calculated UDF when you want PCS Axis to perform 
calculations based on expressions you set up for the UDF. 

• Milepost: Set up a milepost UDF when you want to assign a different milepost 
format to one or more facility types on a pipeline. 

• Standard Picklist: Set up a Standard Picklist UDF when you want to limit data 
entry to a list of valid choices in a selection list. (A Standard Picklist in PCS Axis is 
similar to a validation table in PCS 7.)

• Dynamic Picklist: Set up a Dynamic Picklist with a drop-down list of data items 
that change based on a data item selected in another picklist. This type of picklist 
uses a cascading parent/child relationship allowing you to set up more than five (5) 
levels of interdependent picklists. 

• On/Off Pair : Set up a custom pair of on/off fields when PCS Axis does not 
provide a pair of installed on/off fields for recording inspection readings in a 
data grid or form. This UDF is available for both facility and continuous surveys. 

• Summation: Set up a Summation UDF when you want PCS Axis to perform an 
aggregation for a selected Information, Inspection, or Maintenance field. This 
UDF type supports aggregation on a user-selected target field using any one of the 
following operators: Average, Count, Latest, Maximum, Minimum, and Sum. You 
can also include one or more user-defined filters in the set up of the UDF to further 
filter the results of aggregated data. Summation UDF is a Permanent Information 
field available for use in data grids, forms, reports, and as a filter in scheduling. 

Topics in this section include those in the following list:

• Adding a Normal User Defined Field (page 80)

• Adding a Calculated User Defined Field (page 83)

• Adding a Milepost User Defined Field (page 85)

• Adding a Standard Picklist User Defined Field (page 87)

• Setting Up a Data Entry Field as a Standard Picklist (page 91)

• Adding a Dynamic Picklist User Defined Field (page 97)

• Editing a Picklist (Standard or Dynamic) (page 107)

• Adding an On/Off Pair User Defined Field (page 109)

• Working with a Summation User Defined Field (page 113)
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Adding a Normal User Defined Field
To add a Normal user defined field (UDF), follow these steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want to 
add a UDF. For example, double-click Facility Surveys > CPDM > Test Point > 
Test Point Inspection to display a grid with fields and property settings related 
to the Test Point Inspection data entry grid (Figure 3-36). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-36.  Field and UDF Customizations
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4 Click  Normal in the toolbar to open the Add Normal Field dialog box 
(Figure 3-37). 

5 Type a unique name for the UDF in the Caption field. 

Figure 3-37.  Add Normal Field
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6 Choose the type of field you want to add. Click the down arrow in the Data Type 
field and select one of the following options:

• Character : Supports characters such as A, B, and C. This data type can be 
used for both character and numeric data. If you plan to use mixed data, such 
as a number and a character or dash, define the data type as a character. If you 
plan to create a picklist for the UDF, use the Character data type. For more 
information about picklists, see Adding a Standard Picklist User Defined 
Field (page 87). 

• Numeric: Supports values such as 1, 2, and 3 and numeric values using the 
following format: 999.999 and –99.999. 

• Date: Supports a date format using MM/DD/YYYY (month, day, year), such as 
11/12/2012. 

• Logical: Supports a yes/no selection in the form of a check box to enable or 
disable an option in the data entry grid.

• Memo: Supports more than 255 characters and carriage returns.

• DateTime: Supports a date and time format using HH:MM:SS (hours, 
minutes, seconds) and MM/DD/YYYY (month, day, year). Such as 11:15:45, 12/
11/2012. 

• Integer : Supports a positive or negative whole number, or zero. Such as -2, 4, 
123, and 3,245. 

7 If you selected the Character or Numeric data type earlier, set the length of the 
field by typing the number of characters required for the UDF in the Width field. 

Clicking the up arrow in the Width field increases the value; clicking the down 
arrow decreases the value. 

8 If you selected the Numeric data type earlier, set the number of decimal places 
required for the UDF by typing a value in the Decimals field. 

9 If you selected the Numeric data type earlier and want to set up range checking 
for the UDF, click the Range Checking option and then type a minimum and 
maximum value in the respective fields. 

NOTE: Range checking is the acceptable range of values allowed for data entry in 
a field. Setting up range checking allows PCS Axis to alert the user when an 
incorrect value has been entered. 
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10 Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

The UDF is now available for adding in a data entry grid. If needed, see Working 
with Themes and Filter Groups (page 316) for information about how to add 
fields in a data entry grid. 

Adding a Calculated User Defined Field
The procedure in this section includes an example that describes how to define an 
expression for a user defined field (UDF) labeled Shorted P/S. In the example, if 
Casing P/S is below protection criteria (less than or more negative than –0.8495), PCS 
Axis enables Shorted P/S for data entry in the grid. The field is not enabled for data 
entry when Casing P/S meets protection criteria. 

NOTE: An expression is a logical statement with specific conditions that must be met 
before PCS Axis enables the field for data entry. Logical statements are either “true” or 
“false” based on the conditions defined in the expression for the UDF.

To add a Calculated UDF, follow these steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want to 
add a UDF. For example, double-click Facility Surveys > CPDM > Test Point > 
Test Point Inspection to display a grid with fields and property settings related 
to the Test Point Inspection data entry grid (Figure 3-38). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 
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Figure 3-38.  Field and UDF Customizations

4 Click  Calculated in the toolbar to open the Add Calculated Expression 
dialog box. If you want to work with the expression editor in advanced mode, 
click  Switch To Advanced Mode (Figure 3-39).

Figure 3-39.  Add Calculated Expression (Advanced Mode)
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5 Type a unique name for the UDF in the Caption field. Then click the down arrow in 
the Data Type field and select a data type in the selection list, such as Numeric. 

6 If you selected the Character or Numeric data type earlier, set the length of the 
field by typing the number of characters required for the UDF in the Width field. 
Clicking the up arrow in the Width field increases the value; clicking the down 
arrow decreases the value. 

7 If you selected the Numeric data type earlier, set the number of decimal places 
required for the UDF by typing a value in the Decimals field. 

8 Click a toggle button  to open a field category, such as Test Point Inspection 
Fields shown in Figure 3-38, page 84. Double-click a field in the list of fields to add 
it in the Expression field. Define the UDF using the operator and functions buttons. 

NOTE: Hovering the mouse over a function or operation button displays a 
description below the folder tree. 

9 Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. The UDF is now available for adding in a data entry grid. 
If needed, see Working with Themes and Filter Groups (page 316) for 
information about how to add fields in a data entry grid. 

Adding a Milepost User Defined Field
Set up a Milepost user defined field (UDF) when you want to assign a different milepost 
format to a facility type on a pipeline. For example, if coupons require a different milepost 
format than other facility types on a pipeline, set up a milepost UDF and then assign the 
UDF at the facility type level in the Facility Location ID Formats mini-grid of Edit ROW 
Detail (Data Entry > Edit ROW Detail). 

To add a Milepost UDF, follow these steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).
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b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want to 
add a UDF. 

For example, double-click Facility Surveys > Common to All Facilities > ROW 
and Pipeline to display a grid with fields and property settings related to the Edit 
ROW Detail grid (Figure 3-40, page 86). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-40.  Field and UDF Customizations

4 Click  Milepost in the toolbar to open the Add Milepost Field dialog box 
(Figure 3-41). 

5 Type a unique name for the UDF in the Caption field. 

6 Click the down arrow in the Milepost Formats field and select a milepost format 
in the selection list. 

7 Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 
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The UDF is now available for selection in the Facility Location ID Formats mini-
grid of Edit ROW Detail. If needed, see Working with Pipeline Records 
(page 139) for more information. 

Figure 3-41.  Add Milepost Field

Adding a Standard Picklist User Defined Field
A Standard Picklist is a list of acceptable choices for a field in a data entry grid that a user 
selects from when entering data. This feature improves data consistency and accuracy by 
allowing users to select from a list of predefined choices instead entering data manually. 

A Standard Picklist contains a list of valid items for selection, a description of each item, 
and a value assigned to each item that determines the sorting order of items in the list. 

NOTE: A Standard Picklist in PCS Axis is similar to a validation table in PCS 7.x. 

To add a Standard Picklist user defined field (UDF), follow these steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).
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b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want to 
add a UDF. 

For example, double-click Facility Surveys > CPDM > Test Point > Test Point 
Inspection to display a grid with fields and property settings related to the Test 
Point Inspection data entry grid (Figure 3-42, page 88). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-42.  Field and UDF Customizations

4 Click  Picklist in the toolbar to open the Select Picklist Type dialog box 
(Figure 3-43). 

5 Click Standard and then click  OK to close the Select Picklist Type dialog box. 
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Figure 3-43.  Select Picklist Type

6 When the Add Picklist Field dialog box opens, type a unique name for the UDF in 
the Caption field (Figure 3-44, page 89). 

7 Set the length of the field by typing the number of characters required for the UDF 
in the Width field. 

Clicking the up arrow in the Width field increases the value; clicking the down 
arrow decreases the value. 

Figure 3-44.  Add Picklist Field

8 Choose an option for displaying the UDF in data entry grids. Click the down arrow 
in the field Cell Style and select one of the following options in the selection list:
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• Show Value: Displays the assigned value of the selected item in the picklist. 

• Show Description: Displays the description of the selected item in the 
picklist.

• Show Value And Description: Displays the assigned value and description of 
the selected item in the picklist. 

• Show Description And Value: Displays the description and assigned value of 
the selected item in the picklist. 

9 Choose an option for displaying items in the picklist. Click the down arrow in the 
field Dropdown Style and select one of the following options in the selection list:

• Show Value: Displays only the assigned value of items in the picklist. 

• Show Description: Displays only the description of items in the picklist.

• Show Value And Description: Displays the assigned value and description of 
items in the picklist. 

• Show Description And Value: Displays the description and assigned value of 
items in the picklist. 

10 Select an option for sorting items in the picklist. Click the down arrow in the field 
Validation Order and select one of the following options in the selection list:

• Value: Sorts items numerically based on values assigned to items in the 
picklist. 

• Description: Sorts items alphanumerically based on the description of items 
in the picklist.

• Defined: Sorts items based on the order of items listed in the Customize 
Picklist dialog box. 

11 If you want the UDF to support multiple selections in the picklist, click the check 
box Allow Multiple Selections. 

12 If you want the UDF to allow data entry of other data in addition to picklist items 
for selection, click the check box Allow Other Entry. 

13 To add picklist items for selection, follow these steps:

a Click the message Click here to add new row to add an empty row of fields 
for data entry (Figure 3-44, page 89).

b Type a value in the Value field to associate a code number with the picklist 
item. They type a description for the picklist item in the Description field. 
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c Press Enter on the computer keyboard to add another empty row of fields for 
data entry. 

d Type a value in the Value field and then press the Tab key on the computer 
keyboard to advance the cursor to the Description field. Type a description 
for the picklist item. 

e Repeat step 13 c and d as needed until all picklist items have been added. 
When you finish, click  Save to close the dialog box and return to the Field 
and UDF Customizations window. 

The UDF is now available for adding in a data entry grid. If needed, see 
Working with Themes and Filter Groups (page 316) for information about 
how to add fields in a data entry grid. 

Setting Up a Data Entry Field as a Standard Picklist 
A Standard Picklist is a list of acceptable choices for a field in a data entry grid that a user 
selects from when entering data. This feature improves data consistency and accuracy by 
allowing users to select from a list of predefined choices instead entering data manually. 

For example, setting up a picklist with valid repair codes or status conditions allows users 
to choose from a list of valid items instead of typing information to describe the repair 
status or condition of a facility test station or pipeline. 

A Standard Picklist contains a list of valid items for selection, a description of each item, 
and a value assigned to each item that determines the sorting order of items in the list. 

NOTE: A Standard Picklist in PCS Axis is similar to a validation table in PCS. 

To set up a data entry field as a Standard Picklist, follow these steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).
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b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry field you want 
to set up as a Standard Picklist. 

For example, double-click Facility Surveys > Common to All Facilities > 
Maintenance to display a grid with fields and property settings related to all 
Maintenance data entry grids (Figure 3-45). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

4 Using the horizontal scroll bar near the bottom of the grid, display the grid column 
labeled Grids–Picklist Definition. Then select the data entry field you want to set 
up as a Standard Picklist. For example, select Repair Priority as shown in the 
following example. 

Figure 3-45.  Field and UDF Customizations
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5 Convert the selected data entry field to a Standard Picklist field. Click the edit 
icon  in the Grids-Picklist Definition field for the data entry field selected 
earlier, such as Repair Priority (Figure 3-45, page 92). 

When a data entry grid includes existing data for the data entry field you convert 
to a Standard Picklist, PCS Axis displays a message to notify you of the number of 
affected records. You can either click Yes in the message to continue converting the 
field to a Standard Picklist or No to cancel the operation. Selecting Yes allows PCS 
Axis to use existing data as valid items for selection in the Standard Picklist. Using 
the merge button  allows you to edit these selection items as needed (Figure 3-
46). 

If you decide later you want to convert the Standard Picklist to a normal data 
entry field, click the revert button  and then click Yes when a confirmation 
message displays. PCS Axis then re-populates affected fields in the data entry grids 
with unaltered data that was available prior to the field conversion. 

Figure 3-46.  Field and UDF Customizations
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6 Click the edit icon  again for the data entry field converted earlier to a Standard 
Picklist to open the Edit Picklist Field dialog box (Figure 3-47). 

Figure 3-47.  Edit Picklist Field
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7 Choose an option for displaying the UDF in data entry grids. Click the down arrow 
in the field Cell Style and select one of the following options in the selection list:

• Show Value: Displays the assigned value of the selected item in the Standard 
Picklist. 

• Show Description: Displays the description of the selected item in the 
Standard Picklist.

• Show Value And Description: Displays the assigned value and description of 
the selected item in the Standard Picklist. 

• Show Description And Value: Displays the description and assigned value of 
the selected item in the Standard Picklist. 

8 Choose an option for displaying items in the Standard Picklist. Click the down 
arrow in the field Dropdown Style and select one of the following options in the 
selection list:

• Show Value: Displays only the assigned value of items in the Standard 
Picklist. 

• Show Description: Displays only the description of items in the Standard 
Picklist.

• Show Value And Description: Displays the assigned value and description of 
items in the Standard Picklist. 

• Show Description And Value: Displays the description and assigned value of 
items in the Standard Picklist. 

9 Select an option for sorting items in the Standard Picklist. Click the down arrow in 
the field Validation Order and select one of the following options in the selection 
list:

• Value: Sorts items numerically based on values assigned to items in the 
Standard Picklist. 

• Description: Sorts items alphanumerically based on the description of items 
in the Standard Picklist.

• Defined: Sorts items based on the order of items listed in the Edit Picklist 
Field dialog box. 

10 To add items for selection in the Standard Picklist, follow these steps:

a Click the message Click here to add new row to add an empty row of fields 
for data entry (Figure 3-47, page 94).
Setting Up PCS Axis 95



PCS Axis User and Administrator Guide
b Type a value in the Value field to associate a code number with the picklist 
item. Then type a description for the picklist item in the adjacent Description 
field. 

c Press Enter on the computer keyboard to add another empty row of fields for 
data entry. 

d Type a value in the Value field and then press the Tab key on the computer 
keyboard to advance the cursor to the Description field. Type a description 
for the picklist item. 

e Repeat step 10 c and d as needed until all picklist items have been added. 
When you finish, click  Save to close the dialog box and return to the Field 
and UDF Customizations window. 

The UDF is now available for adding in a data entry grid. If needed, see 
Working with Themes and Filter Groups (page 316) for information about 
how to add fields in a data entry grid. 

For information about how to edit a picklist refer to Editing a Picklist 
(Standard or Dynamic) (page 107). 
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Adding a Dynamic Picklist User Defined Field
Information in this section explains how to add and edit a Dynamic Picklist user defined 
field (UDF). The information is intended for the PCS Axis SysAdmin or a user with 
SysAdmin user permissions. 

A Dynamic Picklist UDF is a dynamic drop-down list with data items that change based 
on a data item selected in another picklist. This dependency uses a cascading parent/child 
relationship. For example, selecting a data item in the drop-down list of picklist A (parent) 
determines which data items are available for selection in the drop-down list of picklist B 
(child). 

Dynamic Picklists are helpful to users when entering data in a data grid or form. It allows 
for easier and more accurate data entry. 

Building a Dynamic Picklist allows you to control the data entered in a field by limiting 
the choices to those in a pre-defined list. For example, instead of a user typing a lengthy 
description for sub-station locations throughout the country, you might want to build a 
Dynamic Picklist with a parent picklist named My Sub-Station Type that includes three 
associated child picklists labeled My Sub-Station State, My Sub-Station County, and 
finally My Sub-Station City. Each of these are dependent upon the other and form the 
Dynamic Picklist. 

Building a Dynamic Picklist is a 2-part process. You begin with creating the initial parent 
picklist as a Standard Picklist and then add and map one or more child Dynamic 
Picklists. Once this process is complete, you can then add the parent and child picklists in 
data entry grids/forms, reports, and prompts sent to the Allegro Field Computer. 

Topics in this section explain how to add and edit a Dynamic Picklist. They include those 
in the following list: 

• Adding the Initial Parent Picklist (page 98)

• Adding a Child Picklist and Mapping Data Items (page 102)

As an example to demonstrate how to build a Dynamic Picklist, information in this section 
uses a 2-level Dynamic Picklist with My Pipeline State as the initial parent picklist and My 
Pipeline County as the associated child picklist. Although Dynamic Picklists support an 
unlimited number of child picklists, the example uses one for clarity purposes. The process 
for adding multiple child picklists is the same as adding one child picklist.
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Adding the Initial Parent Picklist
Complete the following steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-48). 

2 If you want to select a grid layout theme:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Select an item in the Properties panel that includes the data entry grid you want 
to add a Dynamic Picklist UDF. For example, double-click Facility Surveys > 
CPDM > Test Point > Test Point Inspection to display a grid with fields and 
property settings related to the Test Point Inspection data entry grid (Figure 3-
48). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-48.  Field and UDF Customizations
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4 Click  Picklist in the toolbar of the Field and UDF Customizations window 
to open the Select Picklist Type dialog box (Figure 3-49). 

5 Click Standard and then click  OK to close the dialog box.

Figure 3-49.  Select Picklist Type

6 When the dialog box Add Picklist Field opens, set properties for the parent picklist 
in the following manner (Figure 3-50): 

a Type a unique name for the parent picklist in the Caption field. 

b Indicate the number of characters to allow in the name of the parent picklist. 
Type a value in the Width field or use the up/down arrows to select a value. 
Clicking the up arrow increases the value; clicking the down arrow decreases 
the value. 

Figure 3-50.  Add Picklist Field
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7 Choose an option for displaying the parent picklist in data entry grids. Click the 
down arrow in the field Cell Style and select one of the following options in the 
selection list:

• Show Value: Displays the assigned value of the selected item in the picklist. 

• Show Description: Displays the description of the selected item in the 
picklist.

• Show Value And Description: Displays the assigned value and description of 
the selected item in the picklist. 

• Show Description And Value: Displays the description and assigned value of 
the selected item in the picklist. 

8 Choose an option for displaying items in the parent picklist. Click the down arrow 
in the field Dropdown Style and select one of the following options in the 
selection list:

• Show Value: Displays only the assigned value of items in the parent picklist. 

• Show Description: Displays only the description of items in the parent 
picklist.

• Show Value And Description: Displays the assigned value and description of 
items in the parent picklist. 

• Show Description And Value: Displays the description and assigned value of 
items in the parent picklist. 

9 Select an option for sorting items in the parent picklist. Click the down arrow in the 
field Validation Order and select one of the following options in the selection list:

• Value: Sorts items numerically based on values assigned to items in the parent 
picklist. 

• Description: Sorts items alphanumerically based on the description of items 
in the parent picklist.

• Defined: Sorts items based on the order of items listed in the Customize 
Picklist dialog box. 

NOTE: Do not enable the options Allow Multiple Selections and Allow Other 
Entry for the parent picklist. These options do not apply to Dynamic Picklists. 
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10 Complete the following steps to add data items for selection in the drop-down list 
of the parent picklist. 

Figure 3-51 shows an example of two data items labeled OK-1 Oklahoma and TX-
1 Texas as items for selection in the parent picklist My Pipeline States. These data 
items are set up later as child picklists in the section Adding a Child Picklist and 
Mapping Data Items (page 102). 

a Click the message Click here to add a new row to add an empty row of 
fields for data entry.

b Associate a code with the name of the data item (child picklist). Type one or 
more letters, numbers, or a combination of both in the Value field. Then type 
a description for the data item (child picklist) in the Description field. 

c Press Enter on the computer keyboard to add another empty row of fields for 
data entry. 

d Type a value in the Value field and then press the Tab key on the computer 
keyboard to advance the cursor to the Description field. Type a description 
for another data item (child picklist). 

e Repeat step 10 c and d as needed until all data items (child picklists) have 
been added. When you finish, click  Save to close the dialog box and return 
to the Field and UDF Customizations window. 

PCS Axis adds the parent picklist in the list of other fields in the Field and UDF 
Customizations window. 

Figure 3-51.  Add Picklist Field

11 Continue with the next section Adding a Child Picklist and Mapping Data Items 
(page 102). 
Setting Up PCS Axis 101



PCS Axis User and Administrator Guide
Adding a Child Picklist and Mapping Data Items
Complete the following steps to add a child picklist and then map data items in the child 
picklist to data items in a parent picklist: 

1 If the Field and UDF Customizations window is not open, click Tools > Field and 
UDF Customizations to open the window (Figure 3-48, page 98). 

2 Select an item in the Properties panel that includes the initial parent picklist added 
earlier. (See Adding the Initial Parent Picklist on page 98.)

For example, double-click Facility Surveys > CPDM > Test Point > Test Point 
Inspection to display a grid with fields and property settings related to the Test 
Point Inspection data entry grid.

3 Click  Picklist in the toolbar of the Field and UDF Customizations window 
to open the Select Picklist Type dialog box (Figure 3-52). 

Figure 3-52.  Select Picklist Type

4 Click Dynamic in the Select Picklist Type dialog box. Then click the down arrow in 
the adjacent field and select the parent picklist you want to associate with the child 
picklist. Click  OK to close the dialog box.

5 When the dialog box Add Picklist Field (Figure 3-53) opens, set properties and 
add data items for the child picklist in the following manner: 

a Type a unique name for the child picklist in the Caption field. 

b Indicate the number of characters to allow in the name of the child picklist. 
Type a value in the Width field or use the up/down arrows to select a value. 
Clicking the up arrow increases the value; clicking the down arrow decreases 
the value. 
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Figure 3-53.  Add Picklist Field
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6 Choose an option for displaying the child picklist in data entry grids. Click the 
down arrow in the field Cell Style and select one of the following options in the 
selection list:

• Show Value: Displays the assigned value of the selected item in the picklist. 

• Show Description: Displays the description of the selected item in the picklist.

• Show Value And Description: Displays the assigned value and description of 
the selected item in the picklist. 

• Show Description And Value: Displays the description and assigned value of 
the selected item in the picklist. 

7 Choose an option for displaying data items in the child picklist. Click the down 
arrow in the field Dropdown Style and select one of the following options:

• Show Value: Displays only the assigned value of items in the child picklist. 

• Show Description: Displays only the description of items in the child picklist.

• Show Value And Description: Displays the assigned value and description of 
items in the child picklist. 

• Show Description And Value: Displays the description and assigned value of 
items in the child picklist. 

8 Select an option for sorting data items in the child picklist. Click the down arrow in 
the field Validation Order and select one of the following options:

• Value: Sorts items numerically based on values assigned to items in the child 
picklist. 

• Description: Sorts items alphanumerically based on the description of items in 
the child picklist.

• Defined: Sorts items based on the order of items listed in the Customize 
Picklist dialog box. 

NOTE: The options Allow Multiple Selections and Allow Other Entry are 
unavailable for selection when adding a child picklist. 
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9 Complete the following steps to add data items in the child picklist and then map 
these data items to data items in the associated parent picklist. Data items you add 
become selections in the drop-down list of the child picklist.

a Click the message Click here to add a new row to add an empty row of 
fields for data entry.

b Associate a code with the name of the data item. Type one or more letters, 
numbers, or a combination of both in the Value field. Then type a description 
for the data item in the Description field. 

The example below shows a data item labeled TX-1 Travis as an item for 
selection in the child picklist labeled My Pipeline County (Figure 3-54). 

Figure 3-54.  Add Picklist Field

c Click the  parent picklist button to open the dialog box labeled Select 
Parent Picklist Values (Figure 3-55). 

Figure 3-55.  Select Parent Picklist Values
Setting Up PCS Axis 105



PCS Axis User and Administrator Guide
d Map a data item in the parent picklist to the currently selected data item in the 
child picklist. A list of data items related to the parent picklist display in the left 
pane of the dialog box (Figure 3-56). 

• Double-click a data item in the left pane of the dialog box to move the 
data item to the right pane. 

You can also map data items by clicking a data item’s check box and then 
clicking the  right arrow button. A  check mark beside a data item 
indicates that data item is mapped. 

If you want to unmap a data item, double-click the data item in the right 
pane of the dialog box to move it back to the left pane. Or, select the data 
item in the right pane and then click the  left arrow button. 

Figure 3-56.  Select Parent Picklist Values

e Click  Save to save settings and close the dialog box. 

10 To add another data item in the child picklist, follow these steps (Figure 3-57): 

a Press Enter on the computer keyboard to add another empty row of fields for 
data entry in the dialog box Add Picklist Field. 

b Associate a code with the name of the data item. Type one or more letters, 
numbers, or a combination of both in the Value field. Then type a description 
for the data item in the Description field. 

The example below shows a data item labeled OK-2 Marshall as data item for 
selection in the child picklist labeled My Pipeline County (Figure 3-54). 
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Figure 3-57.  Add Picklist Field

c Click the  parent picklist button to open the dialog box labeled Select 
Parent Picklist Values (Figure 3-55, page 105). 

d Map a data item in the parent picklist to the currently selected data item in the 
child picklist (Figure 3-56, page 106). Click  Save when you finish to save 
settings and close the dialog box. 

e To add additional data items in the child picklist, repeat step 10 a through d. 
When you finish adding and mapping all data items in the child picklist, click 

 Save to close the dialog box and return to the Field and UDF 
Customizations window. 

The process for adding a Dynamic Picklist UDF is now complete. You can add 
the Dynamic Picklist (parent and child picklist fields) in the layout theme of a 
data grid, form, or report, as well as in a prompt theme for prompts sent to the 
Allegro Field Computer. Refer to Working with Themes and Filter Groups 
(page 316) for information. For information about editing a picklist, refer to 
Editing a Picklist (Standard or Dynamic) on page 107. 

Editing a Picklist (Standard or Dynamic) 
Information in this section explains how to edit or delete a Standard or Dynamic Picklist 
user defined field (UDF) in Field and UDF Customizations. 

Complete the following steps:

1 If the Field and UDF Customizations window is not open, click Tools > Field and 
UDF Customizations to open the window (Figure 3-48, page 98). 
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2 Select an item in the Properties panel that includes the picklist you want to edit or 
delete. 

For example, double-click Facility Surveys > CPDM > Test Point > Test Point 
Inspection to display a grid with fields and property settings related to the Test 
Point Inspection data entry grid.

3 Select the picklist UDF you want to work with in the grid of the Field and UDF 
Customizations window. 

4 If you want to delete the picklist UDF, click  Delete in the toolbar of the Field 
and UDF Customizations window. Then click  Yes when the Confirm Delete 
message displays. 

5 If you want to add or remove data items in a picklist UDF, navigate to the grid 
column labeled Grids - Pick List Definition and click the  edit icon to open the 
Edit Picklist Field dialog box (Figure 3-58). 

Figure 3-58.  Edit Picklist Field

6 To delete a data item in the picklist UDF, select the data item and then click 
 Delete. When a Delete message displays, click  Yes to delete the data 

item or  No to cancel the operation. 

7 To add a data item in the picklist UDF, follow these steps:

a Click the message Click here to add a new row to add an empty row of 
fields for data entry.

b Associate a code with the name of the data item. Type one or more letters, 
numbers, or a combination of both in the Value field. Then type a description 
for the data item in the Description field. 
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c If you are adding a data item in a child Dynamic Picklist, complete the 
following steps: 

1) Click the  parent picklist button to open the dialog box Select Parent 
Picklist Values (Figure 3-55, page 105). 

2) Map a data item in the associated parent picklist to the new data item in 
the child picklist in the following manner. A list of data items related to the 
parent picklist display in the left pane of the dialog box (Figure 3-56, 
page 106). 

• Double-click a data item in the left pane of the dialog box to move the 
data item to the right pane. 

You can also map data items by clicking a data item’s check box and 
then clicking the  right arrow button. A  check mark beside a data 
item indicates that data item is mapped. 

If you want to unmap a data item, double-click the data item in the 
right pane of the dialog box to move it back to the left pane. Or, select 
the data item in the right pane and then click the  left arrow button. 

d To add another data item, press Enter on the computer keyboard and then 
repeat step 7 a through c. 

8 Click  Save to save settings and close the dialog box. 

Adding an On/Off Pair User Defined Field
PCS Axis provides several pairs of installed on/off fields for recording inspection 
readings in a data grid or form, such as AC P/S and AC IRF; Casing P/S and Casing 
IRF; Foreign P/S and Foreign IRF; Insulator P/S and Insulator IRF; and Structure P/S 
and Structure IRF. 

If PCS Axis does not provide an installed pair of on/off fields you can use to record 
inspection readings for a facility or continuous survey, create a custom On/Off Pair user 
defined field (UDF). Information in the following procedure explains how to use Field and 
UDF Customizations to add an On/Off Pair UDF. 

NOTE: Editing an On/Off Pair UDF is not currently supported. This feature will be 
available in a future release of PCS Axis to allow changing or deleting an On/Off Pair UDF. 

The current version of PCS Axis does not support editing an On/Off Pair user defined 
field. 
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Complete the following steps:

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 

3 Double-click Facility Surveys or Continuous Surveys in the Properties panel to 
open the selected folder. Then select the Inspection data grid you want to set up 
an On/Off Pair UDF. 

For example, to set up an On/Off Pair UDF for the Test Point Inspection data grid, 
double-click Facility Surveys > CPDM > Test Point. Then click Test Point 
Inspection (Figure 3-59, page 111). Likewise, to set up an On/Off Pair UDF for 
the Edit ISM Data grid, double-click Continuous Surveys > CIS Surveys. Then 
click Surveys. 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 
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Figure 3-59.  Field and UDF Customizations

4 Click  On/Off Pair in the toolbar to open the Add On/Off Pair Fields dialog 
box (Figure 3-60). 

Figure 3-60.  Add On/Off Pair Fields

5 Type a unique name in the fields On Field Caption and Off Field Caption. 

6 Click the down arrow in Data Type and select Numeric or Integer. 

A Numeric data type is a positive or negative value with decimal precision, such as 
1.123 and –1.123. An Integer data type is a positive or negative whole number, 
such as 5 and –5. 
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7 If you selected the Numeric data type earlier in step 6 (page 111), set the length 
of the field using the Width and Decimal fields (Figure 3-60, page 111). 

Clicking the up arrow in Width or Decimal fields increases the value; clicking the 
down arrow decreases the value. 

8 If you want PCS Axis to apply Range Checking to the On reading in the On/Off 
Pair, complete the following steps. 

NOTE: Range checking is the acceptable range of values allowed for data entry in 
an inspection field.  
 
Setting up range checking allows PCS Axis to alert the user when an incorrect value 
has been entered in an inspection field. For example, if the acceptable range of 
values is in a range of -10 to 0 and the user enters a value that is outside this range, 
a warning displays allowing the user to correct the invalid entry. Data entry errors 
are less likely to occur when using Range Checking. For more information, see 
Setting Up Range Checking for Inspection Fields (page 77). 

a Click the check box On Range Checking. 

b Type a minimum range value in the On Minimum field. 

c Type a maximum range value in the On Maximum field. 

9 If you want PCS Axis to apply Range Checking to the Off reading in the On/Off 
Pair, complete the following steps: 

a Click the check box Off Range Checking. 

b Type a minimum range value in the Off Minimum field. 

c Type a maximum range value in the Off Maximum field. 

10 The On/Off Pair UDF is now available for adding in a data entry grid. If needed, 
see Working with Themes and Filter Groups (page 316) for information about 
how to add fields in a data grid or form. 
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Working with a Summation User Defined Field
A Summation user defined field (UDF) is a Permanent Information field available for 
use in a data grid, form, report, or as a filter in scheduling. It is a simple yet powerful 
UDF that provides useful information when analyzing pipeline data. 

The function of a Summation UDF is to aggregate data for a target field using one of the 
following operators: Average, Count, Latest, Maximum, Minimum, and Sum. As an 
option, you can also include one or more filters that run either before or after the data 
aggregation. 

EXAMPLE:  Set up a Summation UDF using Structure P/S as the target field and Average 
as the operator. Include a Calculated UDF as a filter in the Summation UDF that is set up 
to find the variance between the actual and average Structure P/S reading for test points. 
The expression for the Calculated UDF is ABS([My Summation Name] – [Structure P/S]). 
Add the Summation and Calculated UDFs in the Test Point Inspection data grid to view 
the results of the data aggregation. For more information about working with a 
Calculated UDF, refer to Adding a Calculated User Defined Field (page 83). 

Information in this section explains how to work with a Summation user defined field. 
Topics include those in the following list:

• Adding a Summation User Defined Field

• Editing a Summation User Defined Field (page 118)

Adding a Summation User Defined Field
Complete the following steps to add a Summation UDF: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 If you want to select a grid layout theme, follow these steps:

a Click  Customize to open the Column Selections dialog box (Figure 3-32, 
page 74).

b Click the down arrow in Select a Layout Theme and select a theme in the 
selection list. 

c Click  Save to close the dialog box and return to the Field and UDF 
Customizations window. 
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3 Double-click Facility Surveys > Common to All Facilities in the Properties 
panel. Then click Permanent Information to display a grid with fields and 
property settings common to all facilities (Figure 3-61). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

Figure 3-61.  Field and UDF Customizations

4 Click  Summation in the toolbar to open the Add Summation Field dialog 
box (Figure 3-62, page 115). 
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Figure 3-62.  Add Summation Field

5 Type a unique name for the Summation UDF in the Caption field. 

6 Select a target field in the list of fields in the selection panel. For example, click the 
 expand arrow for Test Point Inspection Fields, then double-click Structure P/S. 

A  green check mark indicates a selection (Figure 3-63, page 116). 

7 Select an Operator option. For example, Average is selected in the following 
figure (Figure 3-63, page 116). 

The Summation expression displays in the top right-hand corner of the dialog box, 
such as Average: Structure P/S shown in the following example. 

8 Click  Save to save settings. 

9 If you want to add an optional AND filter group to the Summation UDF, continue 
with step 10 (page 116). To add an optional OR filter group, continue with step 
11 (page 117). Otherwise, continue with step 12 (page 118) to close the Add 
Summation Field dialog box. 
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Figure 3-63.  Summation Target Field

10 If you want to include one or more optional AND filters in the Summation UDF, 
complete the following steps. Data results produce a subset of records that meet 
all filter conditions included in the filter group. 

a Click the  Filters button to open the Filters panel. 

b Click  New ‘And’ Group to open the filter properties group box (Figure 3-
64, page 117). 

c Type a name for the filter group in the field Filter Group Caption. 

d Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

e If you want to set up additional filter criteria, click  Add to display an 
additional set of filter selection fields. Select a PCS Axis field, operator, and 
one or more filter conditions to set up filter criteria. 

f Repeat step 10 b through e as needed. When you finish, click the  Filters 
button to close the Filters panel. Then continue with step 12 (page 118). 
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Figure 3-64.  New ‘And’ Filter

11 If you want to include one or more optional OR filters in the Summation UDF, 
complete the following steps. Data results produce a subset of records that meet 
any filter condition(s) included in the filter group. 

a Click the  Filters button to open the Filters panel. 

b Click  New ‘Or” Group to open the filter properties group box 
(Figure 3-65). 

c Type a name for the filter group in the field Include records that match any 
of these conditions. 

d Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions. 

e If you want to set up additional filter criteria, click  Add to display an 
additional set of filter selection fields. Select a PCS Axis field, operator, and 
one or more filter conditions to set up filter criteria. 

f Repeat step 11 b through e as needed. When you finish, click the  Filters 
button to close the Filters panel. Then continue with step 12. 
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12 Click  Save and then the close button  to close the Add Summation Field 
dialog box. 

Figure 3-65.  New ‘Or’ Filter

Editing a Summation User Defined Field
When you want to edit a Summation UDF previously added in PCS Axis, follow these 
steps: 

1 Click Tools > Field and UDF Customizations to open the Field and UDF 
Customizations window (Figure 3-29, page 72). 

2 Double-click Facility Surveys > Common to All Facilities in the Properties 
panel. Then click Permanent Information to display a grid with fields and 
property settings common to all facilities (Figure 3-61, page 114). 

NOTE: Clicking the Properties bar collapses the Properties panel allowing you to 
view more of the grid. Clicking the bar again expands the panel. 

3 Select the Summation UDF you want to edit in the grid of the Field and UDF 
Customizations window. Then navigate to the grid column labeled System-
User Defined Summation Definition and click the … ellipsis button 
Figure 3-66). 
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Figure 3-66.  System-User Defined Derivation Definition

4 When the dialog box Edit Summation Field opens, change UDF settings as 
needed, such as selecting a different target field in the list of fields in the selection 
panel or a different Operator option (Figure 3-67). 

5 If the Summation UDF includes filter settings you want to change, click the 
 Filters button to open the Filters panel and make changes as needed. 

Use filter selection fields to set up filter criteria. Select a PCS Axis field, 
operator, and one or more filter conditions.
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6 Click  Save to save settings and return to the Field and UDF Customizations 
window. 

Figure 3-67.  Edit Summation

Using an Application Scheme
An application scheme is a group of named property settings that change the overall 
appearance of the PCS Axis interface. Currently PCS Axis only provides a default 
application scheme which cannot be customized (Tools > Application Schemes). Future 
software enhancements will allow you to create application schemes for customizing the 
PCS Axis interface, such as choosing a different color scheme. 

Choosing a Printer for PCS Axis
PCS Axis uses your computer’s default printer to print reports and graphs. If a color printer 
is available, you may want to print graphs on a color printer. If you need to add or set up a 
local or network printer, contact your company’s network administrator or IT department 
for assistance. 
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Working with Pipeline Series
Information in this section explains how to work with Pipeline Series. Topics include those 
in the following list: 

• About Pipeline Series

• Adding and Applying Pipeline Series (page 122)

About Pipeline Series
When a discontinuity occurs in a pipeline, use Pipeline Series to adjust facility numbers on 
the pipeline. A discontinuity typically occurs when an extension is added to the pipeline; 
the pipeline is re-routed; or when a company designates two pipelines as parallel lines. 
Instead of physically renumbering pipeline location numbers on-site, Pipeline Series 
allows you to shift pipeline numbering in PCS Axis using Relative Milepost locations. 

A Pipeline Series is an ordered list of milepost locations with a starting milepost and an 
ending milepost that serve as connectors to preceding and subsequent Pipeline Series. 
All Pipeline Series snapped end to end map the pipeline. Multiple connected Pipeline 
Series form a Pipeline Series chain. 

Additional characteristics of Pipeline Series include those in the following list:

• All facilities on the pipeline must be assigned to a Pipeline Series when a Pipeline 
Series is used with a segment of the same pipeline. An entire pipeline can be made 
up of several Pipeline Series. 

The starting milepost of a Pipeline Series corresponds to the starting milepost for 
a segment of the pipeline. The ending milepost of the Pipeline Series corresponds 
to the ending milepost for the same segment of pipeline. Each Pipeline Series 
joins together, end-to-end, to make up the entire pipeline. Pipeline Series defines 
each segment and is then used to calculate the Relative Milepost. 

• A pipeline with several different numbering schemes can be converted into a 
sequential line using a Pipeline Series for each segment of the pipeline. This 
allows you to graph the entire distance of the pipeline using the Relative Milepost.

• Pipeline Series supports negative milepost locations. This helps identify milepost 
locations that are in an opposite direction of other milepost locations in a series. 

• Red facility records in a data entry grid identify milepost numbers that require a 
Pipeline Series be applied to the record. 
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Adding and Applying Pipeline Series
The procedure in this section describes how to add a Pipeline Series definition and then 
apply it to effected milepost numbers in a facility data entry grid. The example in the 
procedure adds a pipeline extension with negative milepost locations as shown in the 
following example (Figure 3-68). 

Figure 3-68.  Example of an Extended Pipeline with Mileposts Set in Reverse Order
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NOTE:  In the example above, PCS Axis calculates relative milepost 40+00 
as the end of Series A and the beginning of Series B. 
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To add and apply a Pipeline Series, follow these steps:

1 Click the Select ROWs button  to open the Select ROWs window (Figure 3-69). 
Select one or more pipeline segments with facilities you want to work with, then 
click  Save to close the window.

Figure 3-69.  Select ROWs

2 Select the PCS Axis module you want to work with, such as the CPDM module. Click 
Modules > Cathodic Protection Data Manager (CPDM). 

3 Click Data Entry > Pipeline Series to open the Pipeline Series window 
(Figure 3-70). 

Figure 3-70.  Pipeline Series
Setting Up PCS Axis 123



PCS Axis User and Administrator Guide
4 Click  Add and then select the ROW Code and Pipe you want to work with in 
the dialog box that opens (Figure 3-71). 

Figure 3-71.  Select Right Of Way Code And Pipeline

5 Click  Save to display required field(s) for data entry. Required fields are 
identified with the  icon, such as Series Number, Start Milepost, and End 
Milepost in the next figure (Figure 3-72). 

6 Type a unique identifier for the Pipeline Series in the Series Number field. This 
field accepts up to 10 alphanumeric characters including spaces and special 
characters, such as a hyphen (–) or pound sign (#). 

7 Set the Pipeline Series start and end milepost numbers. Type the starting milepost 
in the Start Milepost field and the ending milepost in the End Milepost field. 

The starting milepost of the Pipeline Series corresponds to the starting milepost 
for a segment of the pipeline. The ending milepost of the Pipeline Series 
corresponds to the ending milepost for the same segment of pipeline. 

Figure 3-72.  Add Record
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8 Click  Save to close the dialog box and add the record in the Pipeline Series 
grid. 

9 If you want to add a description or other type of information for the Pipeline Series, 
type the information in the Description field. This field supports up to 30 
alphanumeric characters. 

10 If you want to add another Series, complete the following steps to create a pipeline 
Series chain (Figure 3-73): 

a Repeat step 4 through step 9 to add another Series. 

b Click the down arrow in the Previous Series field and select the Series that 
precedes the currently selected series. 

c Repeat step 10 to add additional Series in the chain as needed. 

NOTE: PCS Axis uses the preceding Series of each Series in a chain to calculate the 
Relative Milepost. All Series in a chain except the first Series require that you 
identify the Previous Series (Figure 3-73). 

The following example illustrates a pipeline Series chain with two Series in the 
chain (Figure 3-73). Series A was added for the original pipeline segment with a 
start and end milepost of 0+00 and 40+00 respectively. Series B was added for a 
pipeline extension. Because the mileposts are in reverse order in Series B, the 
Pipeline Series is set up with a start and end milepost of –38+00 and 0+00 
respectively. Also see Figure 3-71 (page 124) for an illustration of a pipeline Series 
chain with calculated Relative Mileposts. 
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Figure 3-73.  Pipeline Series

11 Click the  close button to close the Pipeline Series window. 

When a message similar to the following example displays, click  OK to apply 
pipeline Series to effected mileposts (Figure 3-74). 

The following message displays to notify you of the facilities that need to have 
pipeline Series applied in the facility data entry grid. Red facility records in the data 
entry grid identify milepost numbers that require a pipeline Series applied to the 
record. 

Figure 3-74.  Pipeline Series Message
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The remaining steps explain how to apply pipeline Series to effected mileposts in a 
data entry grid. 

12 Open the data entry grid with the mileposts you want to apply pipeline Series, 
such as the Test Point Inspection data grid shown in the next example (Figure 3-
75, page 127). 

NOTE: Red facility records in the data grid identify milepost numbers that require 
a Pipeline Series applied to the record. 

13 Select the Series field for a facility record in the grid to display a drop-down arrow. 
Click the arrow and select a pipeline Series in the selection list. Repeat this step for 
each effected facility record in the data grid. 

Figure 3-75.  Pipeline Series

14 Click  Refresh to update data in the grid. 

PCS Axis automatically calculates the Relative Milepost for each facility record 
assigned a pipeline Series in the data entry grid. In the following example, PCS Axis 
calculates relative milepost 40+00 as the end of Series A and the beginning of 
Series B. (Figure 3-76). 
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Figure 3-76.  Relative Milepost

Working with a User Defined Module
If you need to manage compliance data for facility types not included in PCS Axis, use 
Custom Module Management (CMM) to add a user defined module. For example, adding 
a user defined module with user defined facility types allows you to manage compliance 
data for major components associated with a cathodic protection electrical system or a gas 
odorization system. 

IMPORTANT: PCS Axis supports up to ten (10) user defined modules with each module 
supporting up to ten (10) user defined facility types. 

CMM is an optional add-on feature that requires an activation key for operation. If your 
company has purchased the CMM module, use the information in this section to set up a 
user defined module with user defined facility types. Topics in this section include those in 
the following list:

• Understanding a User Defined Module (page 129)

• Adding a User Defined Module (page 131)

• Deleting a User Defined Module (page 135)
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Understanding a User Defined Module
A user defined module (UDM) provides the same features and functions as a system 
installed module. It is available for use throughout PCS Axis, such as the Modules, Data 
Entry, and Reports/Graphs menus; Field and UDF Customizations, Bridge, and Email 
Notification. 

Likewise, the following features provided with a system installed module are also provided 
with a user defined module: Information, Inspection, and Maintenance data entry grids; 
layout, sorting, and filter themes; reports and graphs; and optional routes, schedules, and 
scheduling types for user defined facility types. 

The process for adding a user defined module includes the following tasks (Figure 3-77):

• Add a user defined module with user defined facility type(s) in Custom Module 
Management (Modules > Custom Module Management).

• Add one or more user defined fields (UDFs) as needed to be used throughout the 

• system, such as data entry grids, reports, and graphs (Tools > Field and UDF 
Customizations). 

• Set up data entry grids (Data Entry > Edit <module> Data); reports and graphs 
(Reports/Graphs); scheduling (Data Entry > Edit Schedule Settings and Define 
Schedules); and routes (Data Entry > Define Routes). 
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Figure 3-77.  Workflow for Adding a User Defined Module
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Adding a User Defined Module
Information in this section explains how to add a user defined module with one or more 
user defined facility types. A user defined module supports up to six (6) user defined 
facility types. 

Complete the following steps: 

1 Click File > Select ROWs to open the Select ROWs window (Figure 3-78). Select 
one or more pipeline segments and then click  Save to close the window. 

Figure 3-78.  Select ROWs

2 Open CMM and add a user defined module. Click Modules > Custom Module 
Management >  Add Module (Figure 3-79). 

PCS Axis adds a group of fields for the new user defined module. Fields with an 
error icon  indicate a required data entry field. 
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Figure 3-79.  Custom Module Management

3 To set Name, Acronym, and Color properties for the user defined module, follow 
these steps (Figure 3-80): 

a Type a name in the Name field. The field accepts up to 50 alphanumeric 
characters including spaces and special characters. 

NOTE: Clicking the  toggle button in the  information bar displays 
information related to required property settings. 

b Type an acronym in the Acronym field. This field accepts up to four (4) alpha 
characters. It does not support numeric or special characters. 

c Click the down arrow in the Color field and select a color in the color palette. 

The following example shows a user defined module with the following 
property settings: module name is My CP Electrical System, module acronym 
is MCPE, and module color is Aquamarine. 
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Figure 3-80.  Custom Module Management

4 To set properties for one or more user defined facility types, complete the 
following steps (Figure 3-81):

a Type a name in the Name field. The field accepts up to 30 alphanumeric 
characters including spaces and special characters. The name you provide 
appears in data entry grids, reports and graphs, scheduling, routes, and so on. 

b Type a longer name for the user defined facility in the Long Name field. This 
field accepts up to 40 alphanumeric characters including spaces and special 
characters. 

c Type an acronym for the user defined field in the Short Name field. The field 
accepts up to four (4) alpha characters. It does not support numeric or special 
characters. 

d If you want the facility type available for selection when setting up a schedule, 
click the check box Is Schedulable. Likewise, click the check box Is Routable 
to have the facility type available for selection when setting up a route. 

The following example shows a user defined module with user defined facility 
types labeled Electric Meters, Transformers, Power Poles, and Circuit 
Breakers (Figure 3-81). 
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Figure 3-81.  Custom Module Management

e To add another user defined facility type, repeat step 4 a through d. You can 
add up to six (6) user-defined facility types for each user defined module. 

f Click  Save. 

NOTE: Clicking the  close icon in the group box of user defined facility types 
closes the group box. Use this feature when you only want to view property 
settings of user defined modules. To re-open the group box, click the  open icon. 

5 Click  to close the Custom Module Management window. 

6 Set up the following system features as needed:

a Add fields related to the user defined module in Fields and UDF 
Customizations > Facility Surveys. Refer to Setting Properties in Field and 
UDF Customizations (page 68).

b Set up data entry grid Layouts, Sorts, and Filters. Refer to Working with 
Themes and Filter Groups (page 316). 

c Set up reports and graphs. Refer to Using Reports and Graphs (page 709).

d Set up scheduling and routes. Refer to Using a Schedule (page 453) and 
Using a Route (page 381). 
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Deleting a User Defined Module
Deleting a user defined module also deletes all user defined facility types, reports, graphs, 
schedules, routes, and facility data associated with the module. 

To delete a user defined module, follow these steps:

1 Click File > Select ROWs to open the Select ROWs window (Figure 3-82). Select 
one or more pipeline segments and then click  Save to close the window. 

Figure 3-82.  Select ROWs

2 Open CMM. Click Modules > Custom Module Management. 

3 Click the  delete button for the user defined module you want to delete 
(Figure 3-83). 
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Figure 3-83.  Custom Module Management

4 When the warning message Confirm module delete opens, click  Delete to 
delete the module or  Cancel to cancel the operation. 

5 Click  to close the Custom Module Management window. 
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