
Managing the Database

Information in this section explains how to manage the PCS Axis database. The 
information is intended for the PCS Axis Administrator or a user with SysAdmin 
permissions. Topics in this section include those in the following list: 

• Running Database Integrity Check

• Running Reindex Database (page 795)

• Using Data Modification Utility (page 796)

Running Database Integrity Check
In the unlikely event data becomes corrupted in the database, use Database Integrity 
Check to identify and resolve instances of data inconsistencies. The process performs an 
audit of the database searching for issues that may prevent PCS Axis from loading or 
performing basic functions. Its purpose is to clean up data issues that may cause problems 
for users. For example, database issues the auditing process detects and corrects include:

• Orphan records.

• Invalid hierarchy nodes.

• Outdated or incorrect derived fields. See Working with Derived Fields (page 226) 
for information about derived fields. 

• Invalid field characters, hierarchy nodes, or folders outside hierarchy levels.

• Duplicate or missing right-of-ways (ROWs) and pipes. 

• Blank hierarchy level names and empty or missing hierarchy folders.

• Missing base effective dates (facilities and pipelines).

• Invalid foreign keys in database tables. (A foreign key is a field in a database table 
that refers to a record in another database table.) 

To run Database Integrity Check :

• Click File > Database Integrity Check to open the Data Auditor window 
(Figure 18-1). Then click  Run. 

The message Running displays during the database audit process. 
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Figure 18-1.  Data Auditor

When the process completes, the results of the database audit display in the Data 
Auditor window (Figure 18-2). You can select and then copy text in the window to 
the Windows clipboard. The copied text can then be pasted in another software 
program such as Microsoft Excel or Word. 

Figure 18-2.  Database Integrity Check Completed
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Running Reindex Database 
The PCS Axis database uses indexes to accelerate the process of locating records in the 
database. As you add and delete records, these indexes become fragmented which in turn 
slow down database performance. The Reindex Database process restores database 
efficiency by updating the indexes. 

IMPORTANT: Before running Reindex Database, it is recommended that you make a 
backup of the PCS Axis database using Microsoft SQL Server Management Studio (SSMS). 
For more information about SSMS, see the AI document entitled PCS Axis Database 
Backup and Restore. 

To run Reindex Database:

1 Click Tools > Job Service Viewer to open the Job Service Console window 
(Figure 18-3). 

2 Click  Reindex Database. 

Figure 18-3.  Job Service Console
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3 When a warning message opens, click  Yes to continue the reindexing process 
(Figure 18-4). 

Figure 18-4.  Warning Message

Status information displays in the queue while running Reindex Database 
(Figure 18-5). When the process completes, status information then displays in the 
Job History panel. 

Figure 18-5.  Reindex Database Running

Using Data Modification Utility
Data Modification Utility is a stand-alone feature that allows you to permanently move 
pipeline ROW records, including subfacility, inspection, and maintenance records, from 
one facility to another facility. Use this feature when splitting or combining pipeline 
segments.
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IMPORTANT: Only users with SysAdmin privileges will be able to access and use the Data 
Modification Utility.

Topics in this section include those in the following list and are intended for users with 
SysAdmin permissions: 

• Moving Facility Records

• Moving Sub Facility Records (page 801)

• Moving Inspections Records (page 803)

• Moving Maintenance Records (page 806)

Moving Facility Records
Information in this section explains how to move facility records from one ROW to another 
ROW. 

Complete the following steps:

1 Click Tools > Data Modification Utility to open the Data Modification Utility 
window (Figure 18-6).

Figure 18-6.  Data Modification Utility - Facility
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2 Select a ROW in the top Select ROWs panel that will be moved to another ROW. 
This is the source ROW.

3 Select a ROW in the lower Select ROWs panel where the records will be moved. 
This is the target ROW. The records from the top panel are moved to the ROW 
selected in the lower panel.

NOTE: You cannot select the same ROW that was selected in the top panel.

4 Select the facility type(s) you want to work with using the method described in 
either step a or step b:

a To select a facility type, click the facility type option button and then click the 
down arrow and select a facility type in the list, such as  [PCS] Rectifier 
Survey (Figure 18-7). 

Figure 18-7.  Facility Type Theme Option

b To select multiple facility types, click the Ad Hoc Theme option button and 
then click the check box for one or more facility types, such as Test Point, 
Rectifier, and Foreign Bond (Figure 18-8). 

1) Click  Select All to select all the facilities. Click  Clear All to clear all 
facilities.

NOTE: An Ad Hoc Theme only applies to the current session and is not saved. 
A facility type is selected when a check mark appears inside the check box. To 
clear the check mark, click the check box again. 

Facility Type Theme 
Selection List
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Figure 18-8.  Ad Hoc Theme Option

5 Click the Select ROWs and Facility Types bars to close these panels (Figure 18-9).

Figure 18-9.  Facility Move Panels

6 To customize the layout of the facility move panels, click  Customize.

a Add or remove fields as desired.

b Click  OK to save changes and close Edit Layout dialog box.

7 Move records from the top panel to the lower panel in any of the following ways:

a Double-click the name of the record.

b Click the check box next to the name of the record.

c Click  Select All to select all the records. 

Ad Hoc Theme Option

Facility Type Selection(s)
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The records are moved to the lower panel and are highlighted in green (Figure 18-
10).

Figure 18-10.  Moved Records

8 Move records from the lower panel back to the top panel in any of the following 
ways:

a Double-click the name of the record.

b Click the check box next to the name of the record.

c Click  Select All to select all the records. 

d Click  Clear All to clear all records. 

The records are moved back to the top panel and are highlighted in green.

9 To save the changes and permanently move the records, click  Apply.

10 Click  Yes in the Warning dialog box (Figure 18-11) to complete the move.
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Figure 18-11.  Warning Message

Moving Sub Facility Records
Information in this section explains how to move sub facility records from one ROW facility 
to another.

Complete the following steps:

1 Click Tools > Data Modification Utility to open the Data Modification Utility 
window (Figure 18-6).

Figure 18-12.  Data Modification Utility - Sub Facility

2 Select a ROW in the top Select ROWs panel with the subfacility records that will be 
moved to another facility. This is the source ROW.
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3 Select a ROW in the lower Select ROWs panel where the subfacility records will be 
moved. This is the target ROW. The records from the top panel are moved to the 
subfacility selected in the lower panel.

4 Click the Select ROWs bar to close this panel (Figure 18-13).

Figure 18-13.  Sub Facility Move

5 To customize the layout of the subfacility move panels, click  Customize.

a Add or remove fields as desired.

b Click  OK to save changes and close Edit Layout dialog box.

6 Select a facility type from the Facility drop-down menu.

7 Select a subfacility type from the Sub Facility drop down menu.

8 Move subfacility records from the top right panel to the lower right panel in any of 
the following ways:

a Double-click the name of the record.

b Click the check box next to the name of the record.

c Click  Select All to select all the records. 

The records are moved to the lower right panel and are highlighted in green.
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9 Move subfacility records from the lower right panel back to the top right panel in 
any of the following ways:

a Double-click the name of the record.

b Click the check box next to the name of the record.

c Click  Select All to select all the records. 

d Click  Clear All to clear all records. 

The records are moved back to the top right panel and are highlighted in green.

10 To save the changes and permanently move the records, click  Apply.

11 Click  Yes in the Warning dialogs box to complete the move.

Moving Inspections Records
Information in this section explains how to move inspections records from one ROW to 
another.

Complete the following steps:

1 Click Tools > Data Modification Utility to open the Data Modification Utility 
window (Figure 18-6).
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Figure 18-14.  Data Modification Utility - Inspections

2 Select a ROW in the top Select ROWs panel with the inspection records that will be 
moved. This is the source ROW.

3 Select a ROW in the lower Select ROWs panel where the records will be moved. 
This is the target ROW. The records from the top panel are moved to the ROW 
selected in the lower panel.

4 Click the Select ROWs bar to close this panel (Figure 18-15).
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Figure 18-15.  Inspections Move

5 To customize the layout of the inspections move panels, click  Customize.

a Add or remove fields as desired.

b Click  OK to save changes and close Edit Layout dialog box.

6 Select a facility type from the Facility drop-down menu.

7 Move inspection records from the top right panel to the lower right panel in any of 
the following ways:

a Double-click the name of the record.

b Click the check box next to the name of the record.

c Click  Select All to select all the records. 

The records are moved to the lower right panel and are highlighted in green.

8 Move inspection records from the lower right panel back to the top right panel in 
any of the following ways:

a Double-click the name of the record.

b Click the check box next to the name of the record.
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c Click  Select All to select all the records. 

d Click  Clear All to clear all records. 

The records are moved back to the top right panel and are highlighted in green.

9 To save the changes and permanently move the records, click  Apply.

10 Click  Yes in the Warning dialogs box to complete the move.

Moving Maintenance Records
Information in this section explains how to move maintenance records from one ROW to 
another.

Complete the following steps:

1 Click Tools > Data Modification Utility to open the Data Modification Utility 
window (Figure 18-6).

Figure 18-16.  Data Modification Utility - Maintenance

2 Select a ROW in the top Select ROWs panel with the maintenance records that will 
be moved. This the source ROW.
806 Managing the Database



PCS Axis User and Administrator Guide
3 Select a ROW in the lower Select ROWs panel where the records will be moved. 
This is the target ROW. The records from the top panel are moved to the ROW 
selected in the lower panel.

4 Click the Select ROWs bar to close this panel (Figure 18-17).

Figure 18-17.  Inspections Move

5 To customize the layout of the inspections move panels, click  Customize.

a Add or remove fields as desired.

b Click  OK to save changes and close Edit Layout dialog box.

6 Select a facility type from the Facility drop-down menu.

7 Move inspection records from the top right panel to the lower right panel in any of 
the following ways:

a Double-click the name of the record.

b Click the check box next to the name of the record.

c Click  Select All to select all the records. 

The records are moved to the lower right panel and are highlighted in green.
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8 Move inspection records from the lower right panel back to the top right panel in 
any of the following ways:

a Double-click the name of the record.

b Click the check box next to the name of the record.

c Click  Select All to select all the records. 

d Click  Clear All to clear all records. 

The records are moved back to the top right panel and are highlighted in green.

9 To save the changes and permanently move the records, click  Apply.

10 Click  Yes in the Warning dialogs box to complete the move.
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