American Innovations (AI) is pleased to announce version 1.13 of our PCS software. This document explains how to upgrade the PCS database, application, and job service from the previous iteration of PCS to version 1.13 for all installation scenarios.

Upgrading PCS should only occur during planned maintenance times, in which there are no users actively using PCS or the PCS data. Information in this document is intended for your company's IT System Administrator, Database Administrator (DBA), and PCS Administrator.

The job service should be installed on a dedicated network server. There should only be one installation of the job service on a given PCS network environment. The date, time, and time zone settings of the job service's machine must match the settings on the central database server.

For a listing of the recommended environments that the network server with database and job service machines should conform to, refer to System Recommendations (page 2).

The Upgrade PCS for the Client, Server, and Job Service (page 6) section details the preparation for, upgrade to, and configuration of PCS for 1.13.

A separate PCS User Guide contains detailed information for the configuration and use of the PCS application.

The Upgrade Checklist (page 5) provides both a breakdown of the steps required for installation and configuration of PCS. If you have questions or need assistance with the installation, contact PCS Technical Services using the contact information on page 22.
System Recommendations

Server System Recommendations

Table 2-9. Dedicated Central Database Server Recommendations

<table>
<thead>
<tr>
<th>Properties</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Intel Xeon</td>
</tr>
<tr>
<td>Processor Speed</td>
<td>2 Quad Core CPUs at 2.4 GHz or better</td>
</tr>
<tr>
<td>RAM</td>
<td>32 GB</td>
</tr>
<tr>
<td>Operating System</td>
<td>Windows Server 2012 R2, 64-bit</td>
</tr>
<tr>
<td>Relational Database Software</td>
<td>SQL Server 2014 SP2</td>
</tr>
</tbody>
</table>

**NOTES:**

- **RAM:** For optimal performance, additional RAM may be required for larger databases or if a large number of clients will connect to the PCS database at the same time.

- **Microsoft SQL Server:** PCS 1.13 is compatible with a 64-bit version of Microsoft SQL Server 2014 SP2.

  Hosting the PCS database on a shared SQL server may result in reduced performance.

- **Disk Space:** Consult with your company’s IT personnel or DBA to determine where database backups will be created.
Standalone Job Service System Requirements

The following describes the system requirements for the job service.

Table 2-10. Job Service Dedicated Machine Recommendations

<table>
<thead>
<tr>
<th>Properties</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Intel Core i7</td>
</tr>
<tr>
<td>Processor Speed</td>
<td>2.3 GHz or better</td>
</tr>
<tr>
<td>RAM</td>
<td>8-32 GB</td>
</tr>
<tr>
<td></td>
<td>*depends on the largest anticipated job size. See Table 2-11.</td>
</tr>
<tr>
<td>Operating System</td>
<td>Windows Server 2012 R2, 64-bit</td>
</tr>
<tr>
<td>Available Disk Space</td>
<td>720 MB</td>
</tr>
<tr>
<td>Microsoft .NET Framework</td>
<td>Version 4.6.1</td>
</tr>
</tbody>
</table>

Table 2-11. Job Service Memory Recommendations

<table>
<thead>
<tr>
<th>Maximum Anticipated Job Size</th>
<th>Sample Job</th>
<th>Recommended RAM Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Small — up to 8 million pieces of data</td>
<td>50 thousand rows, 125 columns</td>
<td>8 GB</td>
</tr>
<tr>
<td>Medium — up to 16 million pieces of data</td>
<td>100 thousand rows, 125 columns</td>
<td>16 GB</td>
</tr>
<tr>
<td>Large — up to 32 million pieces of data</td>
<td>250 thousand rows, 125 columns</td>
<td>32 GB</td>
</tr>
</tbody>
</table>

NOTES:

- *Microsoft .NET Framework*: If the target computer does not have Microsoft .NET Framework v4.6.1 installed, the PCS installation automatically installs it for you. This feature requires an active Internet connection to complete the installation of .NET Framework v4.6.1.

- *RAM*: If a job has more data than the Job Service can handle efficiently, processing time increases dramatically.
Client System Requirements

Table 2-12. Local Client Computer Requirements

<table>
<thead>
<tr>
<th>Properties</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Intel Core i7</td>
</tr>
<tr>
<td>Processor Speed</td>
<td>2.4 GHz or better</td>
</tr>
<tr>
<td>RAM</td>
<td>8 GB</td>
</tr>
<tr>
<td>Operating System</td>
<td>Windows 10, 64-bit</td>
</tr>
<tr>
<td>Available Disk Space</td>
<td>720 MB</td>
</tr>
<tr>
<td>Display Resolution</td>
<td>1920x1080</td>
</tr>
<tr>
<td>Microsoft .NET Framework</td>
<td>Version 4.6.1</td>
</tr>
</tbody>
</table>

NOTES:
- *Microsoft .NET Framework*: If the target computer does not have Microsoft .NET Framework v4.6.1 installed, the PCS installation automatically installs it for you. The client will need an active Internet connection to complete the installation of .NET Framework v4.6.1.
- *RAM*: 8 GB of RAM is sufficient for average use. However, if a client is accessing a large amount of data in PCS, additional RAM may be necessary to achieve optimal performance.
Upgrade Checklist

The upgrade, and configuration of the PCS server and all PCS User ( ) computers requires the coordination of your company’s IT System Administrator ( ), Database Administrator ( ), and PCS Administrator ( ). The exact breakout of tasks may vary depending on your company’s processes and job descriptions. The person fulfilling the role of Database Administrator (DBA) must have full DBA privileges and be a member of the sysadmin fixed server role.

The following is an overview of the preparation, upgrade, and reconfiguration of PCS on the server and clients:

- Prepare the Server and Clients for an Upgrade (page 6)
  - Synchronize All Subscriber and Allegro Data (page 6)
  - Remove All Subscriptions and Publications (page 6)
  - Disable Email Notifications and Change Tracking (page 7)
  - Disable Change Data Capture (page 7)
  - Stop the PCS Job Service (page 7)
  - Backup the Database (page 8)
- Upgrade the PCS Database and PCS for the Administrator (page 8)
- Upgrade SQL Server (page 12)
- Upgrade PCS for the Job Service and Connect to the Database (page 12)
- Enable PCS Functions (page 16)
  - Open PCS and Enter the PCS Product Key (page 16)
  - Configure Change Tracking (page 16)
  - Enable Email Notification (page 17)
- Start the PCS Job Service (page 17)
- Upgrade the PCS Application on Client Computers (page 19)
  - Upgrade PCS (page 19)
  - Enter the PCS Product Key (if necessary) (page 22)
- Recreate the Publication and Subscriptions (page 22)
Upgrade PCS for the Client, Server, and Job Service

When upgrading the server, clients, and job service to PCS 1.13, the server and clients must be prepared for the upgrade. Once all subscriptions are removed and the appropriate settings are disabled, the PCS database and Administrator’s application should be upgraded first. If upgrading SQL Server to 2014, it’s recommended that it is done after updating the database to 1.13. The PCS job service can then be upgraded, PCS settings can be re-enabled, and the client applications can be upgraded. If using replication, the publication and subscriptions must be set up again.

Prepare the Server and Clients for an Upgrade

Prior to upgrading the server, clients, and job service to PCS 1.13, any existing subscriptions must be synchronized with the server and the subscriptions and publications must be removed. Other settings should be disabled and the job service must be stopped. It's recommended that you also back up the database prior to upgrading PCS.

Synchronize All Subscriber and Allegro Data

Perform the following steps on each remote client computer:

1. In PCS, click Tools > Synchronize Now to open the Synchronize Now dialog box.
2. Click Start.
3. Click OK when the message Synchronization Complete displays to complete the process.

For any Allegro Field Computers that contain new survey data, the survey data should be transferred to the PCS database. Use the Field Computer Receive option to transfer outstanding data to PCS.

Remove All Subscriptions and Publications

Perform the following steps to remove the subscriptions on each remote client computer and remove the publication on the server:
1 On each subscriber’s computer, open SQL Server Management Studio, locate the local subscription in the Replication folder, and delete the subscription.

2 On the publisher’s computer, open SQL Server Management Studio, locate the local publication in the Replication folder, and delete the publication.

**Disable Email Notifications and Change Tracking**

If email notification and change tracking has been enabled, they must be turned off prior to upgrading. To do this, open PCS on the PCS Administrator’s computer. Click on Options in the Tools menu and set the following options:

- Change History — click to clear the Turn On Change Tracking checkbox.
- Email Notification — click to select the Disable Email Notification checkbox.

For more information about the Change History and Email Notification options, refer to the PCS User Guide.

**Disable Change Data Capture**

If your company used CDC-enhanced change tracking, perform the following steps to disable CDC:

1 Connect to your PCS database using Microsoft SQL Server Management Studio.

2 Create a new query to enter SQL commands.

3 Enter the following text in the Query pane:

   ```
   exec configureChangeTrackingCDCSettings @enableCDC = 0
   ```

4 Select the entered text and click ![Execute](image).

**Stop the PCS Job Service**

Complete the following steps to stop the PCS Job Service:

1 Open the Computer Management console on the machine with the job service. To open the console, click the Windows Start button, type Computer Management, and select the Computer Management search result.

2 Double-click Services and Applications in the left pane of the console. Then click Services to display a list of services in the middle pane.
Select **PCS Job Service 1.13** and click **Stop**.

Click **File > Exit** to close the *Computer Management* console.

**Backup the Database**

Prior to upgrading your company’s installations of PCS, backup the PCS database by doing the following:

1. Run Microsoft SQL Server Management Studio (SSMS) and establish a connection to the PCS database.
2. Use SSMS to make a backup of the PCS Axis database.
3. Exit SSMS when you finish.

**Upgrade the PCS Database and PCS for the Administrator**

PCS should already be installed on either a client machine or the server for the PCS Administrator. The following must be done to upgrade PCS for the PCS Administrator and upgrade the database to version 1.13:

1. If you are using the installation DVD to install PCS, insert the DVD in the DVD/CD-ROM drive of the computer. Open Windows Explorer to view the contents of the installation DVD.

If you previously downloaded the installation file using a link in an email from PCS Technical Services, navigate to the location of the installation file.
2 Double-click the **Pcs_1.13.xxx.xxxx.exe** installation file to open the PCS Setup dialog box.

![PCS Installation](image)

**Figure 2-39.** PCS Installation

3 Click **Install** in the PCS dialog box to open **Setup Wizard**.

![Setup Wizard](image)

**Figure 2-40.** Setup Wizard

4 Click **Next** to read the *End-User License Agreement*. To accept the license agreement, click the check box **I accept the terms in the License Agreement** to place a check mark inside the check box.

5 Click **Next** to display **Custom Setup**.
By default the PCS application is selected for installation. Click **Next** and then click **Install** to begin the installation.

**NOTE:** Do not install *PCS Job Service* on a client’s computer.

When the installation completes and after a short delay, *Connection Manager* opens automatically on top of *Setup Wizard*.
Verify the following information in Connection Manager to ensure the correct Server and Database settings:

a. Verify the correct name of the central database server is entered in the Server field. If necessary, enter a new server name followed by the SQL Server instance, if available, in the Server field or click Select in the Server field to select the server in the Select Server dialog box.

b. Verify the correct name of the publication database is entered in the Database field. If necessary, enter a new publication database name in the Database field. Or click Select in the Database field to select the database in the Select Database dialog box.

8. Click Create/Upgrade. The Create Or Update Database window opens, providing status information throughout the upgrade process.

9. When Update completed displays in the window, click Close.

10. Click Save and Close to exit Connection Manager.

11. Click Finish in Setup Wizard and then click Close in the PCS dialog box to close the PCS installation file.
Upgrade SQL Server
If your company is upgrading the central database server to SQL Server 2014, perform the SQL upgrade prior to upgrading PCS. Follow the upgrade instructions provided by Microsoft to upgrade SQL Server 2008 to SQL Server 2014 SP2.

Upgrade PCS for the Job Service and Connect to the Database
The following information is intended for the IT System Administrator and explains how to upgrade the PCS Job Service on a network server. The service should already be installed on a dedicated network server.

A single installation file labeled Pcs_1.13.xxx.xxxx.exe is used to install the PCS Job Service. If Microsoft .NET Framework v4.6.1 is not installed, it will be installed as part of the PCS installation. An active Internet connection is required to complete the installation of .NET Framework v4.5.

Complete the following steps:

1. If you are using the installation DVD to install PCS, insert the DVD in the DVD/CD-ROM drive of the computer. Open Windows Explorer to view the contents of the installation DVD.
   
   If you previously downloaded the installation file using a link in an email from PCS Technical Services, navigate to the location of the installation file.

2. Double-click the **Pcs_1.13.xxx.xxxx.exe** installation file to open the PCS dialog box.

   ![PCS Setup](image)

   **Figure 2-43. PCS Installation**

3. Click **Install** in the PCS dialog box to open **Setup Wizard**.
4 Click Next to read the End-User License Agreement. To accept the license agreement, click the check box I accept the terms in the License Agreement to place a check mark inside the check box. Click Next to display Custom Setup.

5 By default the PCS application is selected for installation. If you are working on the central database server and do not want to install the application on the server, click the down arrow in PCS and select the option Entire feature will be unavailable.

6 By default the PCS Job Service is not selected for installation. To install the service on the server, click the down arrow in PCS Job Service and select the option Entire feature will be installed on local hard drive.
Click Next and then click Install to begin the installation.

When the installation completes and after a short delay, Connection Manager opens automatically on top of Setup Wizard.
Verify the following information in Connection Manager to ensure the correct Server and Database settings:

a. Verify the correct name of the central database server is entered in the Server field. If necessary, enter a new server name followed by the SQL Server instance, if available, in the Server field or click Select in the Server field to select the server in the Select Server dialog box.

b. Verify the correct name of the publication database is entered in the Database field. If necessary, enter a new publication database name in the Database field. Or click Select in the Database field to select the database in the Select Database dialog box.

10. Click Test to verify the connection to the server and database. When the message Connection successful displays, click OK to close the message.

11. Click Save and Close to exit Connection Manager.

12. Click Finish in Setup Wizard and then click Close in the PCS dialog box to close the PCS installation file.
Enable PCS Functions
The PCS Administrator must re-enable the settings removed prior to upgrade, including email notification and change tracking. If enhanced change tracking was used, it must be reconfigured at this time.

Open PCS and Enter the PCS Product Key
Starting with version 1.12, PCS uses product keys rather than license files to provide access to PCS. If you are upgrading PCS from a version prior to 1.12, you will need a 32-character product key. Open PCS. If a product key has not previously been entered, you will be prompted to enter a product key.

![Product Key](image)

Figure 2-47. Product Key

Enter the product key in the field provided and click Apply.

Configure Change Tracking
If your company would like to keep a log of all changes made to PCS data, it is recommended to set up change tracking during the upgrade process. If change tracking was already enabled, it is recommended to verify the change tracking settings in case changes to the PCS database tables and fields require updates to your change tracking setup prior to re-enabling change tracking. If your company uses enhanced changed tracking using CDC, you must also set up CDC in SQL Server again.

Refer to the PCS 1.13 Release Notes provided with the PCS upgrade files for a summary of changes made to the database.

After verifying the fields and tables are configured correctly and, if necessary, configuring CDC in SQL Server, select Options in the Tools menu of PCS and click to select the Turn On Change Tracking checkbox.

Refer to Tracking Data Changes in the PCS User Guide for detailed instructions.
Enable Email Notification

Email notification must been re-enabled so reports can be emailed out according to pre-defined schedules. To do this, select **Options** in the **Tools** menu in PCS and click to clear the **Disable Email Notification** checkbox.

Start the PCS Job Service

The purpose of **PCS Job Service** is to monitor the PCS job queue and initiating jobs as they become available. It must be restarted after upgrading the job service.

Complete the following steps:

1. Complete the following steps to set up a user account for the Job Service to log on as a service. The user account must have access to the central database server.
   
   a. Open the **Computer Management** console. To open the console, click the Windows **Start** button, type **Computer Management**, and select the **Computer Management** search result.

   b. Double-click **Services and Applications** in the left pane of the console. Then click **Services** to display a list of services in the middle pane.

   ![Computer Management Console - Services](image)

   **Figure 2-48.** Computer Management Console - Services

   c. Right-click **PCS Job Service 1.13** and select **Properties** to open the **Properties** dialog box.
d  Click the **Log On** tab and select the option **This account**. To set up a user account to log on as a service, type the user name and password in the appropriate fields. You can also view a list of available user accounts by clicking **Browse > Advanced > Find Now**.

![PCS Job Service Properties (Local Computer)](image)

**Figure 2-49. PCS Job Service 1.13 Properties**

**IMPORTANT:** The user account must have access to the central database server and be a member of the local computer’s *Administrators* group in Windows Computer Management so PCS can write to the event logs. In order to import data from the Bullhorn website, the user account also needs to have Internet access. Refer to *Setting Bullhorn Options* (page 21) in the *PCS User Guide* for information about the URLs that will be accessed.

e  Click **Apply** and then **OK** to close the **Properties** dialog box and return to the **Computer Management** console.

2  Complete the following steps in the **Computer Management** console to start **PCS Job Service**:

a  Select **PCS Job Service 1.13** and then click **Start**.

b  Click **File > Exit** to close the **Computer Management** console.
Upgrade the PCS Application on Client Computers

PCS is now ready to be upgraded on all local and remote client machines. Once upgraded, a product key must be entered. If you are upgrading PCS from a version prior to 1.12, you will need a new 32-character product key.

Upgrade PCS

The following tasks must be done by your company’s IT System Administrator ( ) and PCS User ( ):

1. If you are using the installation DVD to install PCS, insert the DVD in the DVD/CD-ROM drive of the computer. Open Windows Explorer to view the contents of the installation DVD.

   If you previously downloaded the installation file using a link in an email from PCS Technical Services, navigate to the location of the installation file.

2. Double-click the **Pcs_1.13.xxx.xxxx.exe** installation file to open the PCS dialog box.

3. Click **Install** in the PCS dialog box to open Setup Wizard.

![Figure 2-50. PCS Installation](image)
4 Click **Next** to read the *End-User License Agreement*. To accept the license agreement, click the check box **I accept the terms in the License Agreement** to place a check mark inside the check box.

5 Click **Next** to display **Custom Setup**.
By default the PCS application is selected for installation. Click **Next** and then click **Install** to begin the installation.

**NOTE:** Do not install PCS Job Service on a client's computer. When the installation completes and after a short delay, Connection Manager opens automatically on top of Setup Wizard.

---

Verify the following information in Connection Manager to ensure the correct **Server** and **Database** settings:

- **a** Verify the correct name of the central database server is entered in the **Server** field. If necessary, enter a new server name followed by the SQL Server instance, if available, in the **Server** field or click **Select** in the **Server** field to select the server in the Select Server dialog box.

- **b** Verify the correct name of the publication database is entered in the **Database** field. If necessary, enter a new publication database name in the **Database** field. Or click **Select** in the **Database** field to select the database in the Select Database dialog box.

Click **Test** in the Primary pane to verify the connection to the server and database. When the message *Connection successful* displays, click **OK** to close the message.
9 Click Clear in the Subscription pane to delete the existing subscription.

10 Click Save and Close to exit Connection Manager.

11 Click Finish in Setup Wizard and then click Close in the PCS dialog box to close the PCS installation file.

**Enter the PCS Product Key (if necessary)**

Open PCS. If a product key has not previously been entered, you will be prompted to enter a product key.

![Product Key](image)

Figure 2-54. Product Key

Enter the product key in the field provided and click Apply.

**Recreate the Publication and Subscriptions**

If your company is using replication to allow clients to work remotely, you will need to set up the publication on the PCS Administrator’s machine and the subscriptions on all remote client machines again. Replication is only available with SQL Server 2014. For instructions detailing the configuration of the publication and subscriptions, refer to Synchronization in the PCS User Guide.

**Product Support and Training**

PCS Technical Services is available to provide assistance with PCS, accept feedback about PCS, or discuss your organization’s training needs. Use the following information to contact PCS Technical Services:

**Support Email:** pcstechservices@aiworldwide.com

**Support Telephone:** 1-800-229-3404

**American Innovations:** http://www.aiworldwide.com